Struggling with BlackMagic UltraStudio Mini Recorder

  • Hi

    I have just bought a BlackMagic UltraStudio Mini Recorder. I am testing it using the output from another laptop. That is set to 1920 x 1080 on its HDMI output, and it recognises its attached to a Black Magic device.
    I am able to record into Media Express, and madmapper demo will happily display the desktop from the other machine, but Izzy doesn't.
    Live capture settings are shown in the attachment. When I click on Start Live Capture the format line in Sound Input gets filled in, and part of the channel 1 box at the bottom fills with black, these both disappears when I click on Stop Live Capture.
    I am on a Mac running 10.10.2 Isadora Core USB 2.0.5.

  • File attached here fdd998-capturesettings.png

  • just tried selecting Apple rather than Blackmagic, and I can get it to work. When Apple driver is selected the device setting gives me a choice of 10 bit or 8 bit for 1080i 60 setting (as did Madmapper), with the Blackmagic driver there is just one option for 1080i 60, no details of bit depth. The 10bit one is the one that is working for me. HTH

  • Dear @Nick,

    OK, I'm sorry to say you've discovered a bug. When i wrote the Blackmagic support, I assumed that every Blackmagic capture device has an output. But I've discovered recently that this isn't true, i.e., with the Ultra Studio Mini Recorder.
    I am using the output channel to give me a video preview of the incoming video, because it will deliver it as ARGB - which is what I need to conver it to OpenGL etc.. Otherwise, when using the input channels to get the image, it will only deliver YUY; that means I must do a costly (and slow) conversion. (Blackmagic must be doing it on the hardware or in some other more efficient way.)
    In any case, I know about this and will get it fixed as soon as I can. I'm really sorry for the problem. It just never showed up for me because all the Blackmagic devices I have support an output.
    Best Wishes,

  • No problem - its not urgent for me, just got one for tests at the moment.

  • Dear @nick,

    I'll alert you as soon as I get this handled.
    Best Wishes,
  • Beta Platinum

    Hey Mark & Nick,

    I'm testing the same device and not having any luck w/Apple or Black Magic settings.  Any advice appreciated.

  • You need to set the resolution to the resolution of the input to get it to work. If you don't know the resolution then you have to try all the options to see if one works, if it doesn't then I think the most likely problem is the video is a resolution that isn't supported. (assuming all the leads etc are checked as well of course)

  • @Nick,
    Are you using the BM Software to test/set the resolution? If not, would you mind to outline your steps for that?

  • @ckim,

    I also notice that the supported codecs list is not that broad, so that might also present an issue depending on your source.

    Supports:  AVC-Intra, AVCHD, Canon XF MPEG2, Digital SLR, DV-NTSC, DV-PAL, DVCPRO50, DVCPROHD, DPX, HDV, XDCAM EX, XDCAM HD, XDCAM HD422, Apple ProRes 4444, Apple ProRes 422 (HQ), Apple ProRes 422, Apple ProRes (LT), Apple ProRes 422 (Proxy), Uncompressed 8-bit 4:2:2, Uncompressed 10-bit 4:2:2.

  • I used the black magic desktop app to test the unit worked, and tried Madmapper when izzy was having trouble.
    I then used the izzy capture dialog box to set the resolution izzy is trying to capture in from the drop down options.
    Apple worked for me, for the reason Mark described above.
  • Beta Platinum

    @primaldivine + @Nick:

    I thought I tried all the settings but will test again soon and get back.  btw, it worked OK with other apps just not Isadora.

  • I had to use the apple settings to get at the bit depth options

  • Beta Platinum

    OK, got the Apple Settings to work.

  • Beta Tester

    Hi there. I have gone trough a few threads about the BlackMagic UltraStudio Mini Recorder. In Resolume Arena the capture function works great, but there I also have the option to chose SDI or HDMI in put. But in Isadora the Input Settings... is greyed out. Any one have a solution to this? 

    I use a camera that outputs: 1080i 59.94

    I have tried both the Apple Drivers and BMD Drivers and I'm on the MacOS 10.12.5

    All the best. Erik

  • Izzy Guru


    You have to set SDI or HDMI in your system preferences. In the last row there is a blackmagic icon. You also have to close other applications that are using the Mini Recorder, only one can have access at the same time.

    Best Michel

  • Beta Tester

    Great! Thanks for the quick reply Michel! Now it works like a charm : )