Finder puts itself on top when auto starting



  • Hi,

    I have a mac mini in a museum installation, using Macosx 10.9.5\. It is programmed to start Isadora on startup, and to show stages. There is only one projector attached - no second screen. I use the latest version of Isadora, didn't unlock/buy the upgrade yet.
    The problem is that the finder shows in front with Isadora playing nicely in the back (unfortunately with the finder thing showing at the top of the screen). Clicking on the Isadora screen solves the problem. But it is an automatic installation, there is nobody to click.
    What to do?
    Thanks!
    Peter Missotten - de Filmfabriek


  • Not sure if there is an Izzy preference for this, but you could use an applescript to move isadora to the front.

    delay (10)

    tell application "IsadoraCore USB Key"

    activate

    end tell

    Paste this into script editor - you will need to change the app name to match your version, and it may ask you to locate the app. Save it as an app and set it to run at startup too.

    Adjust the delay value so that everything else has a chance to start up (leave isadora auto starting by your current method).


    The activate command will bring isadora to the front.


    HTH



  • I have the eact same issue and I solved it using the above. I saved the script as an app and load it on start up. Works a treat.

    FYI I made this a while back - may be some help to you:
    https://vjskulpture.wordpress.com/2012/12/12/configuring-an-apple-mac-for-commercialinstillation-use/ 


  • Hello,

    I have done the same, here is the app (essentially the app made from the same script as Skupture).
    There is another problem with Isadora, when you dont have separate screen for command, the Isadora screen (with actors etc.) come in front of proper movie screen (it was my case with 4 screen, as you with 1 screen…).
    My way is to uncheck "show stage at startup" in preference, to wait 5" at startup with a delay (leaving the "Isadora first" app to work), and then show stage with the actor.
    It works perfectly.
    Hope that helps,
    jacques

    f5daae-isadorafirst.app.zip



  • Dear @PeterFilmfabriek,

    First, thanks to @jhoepffner for helping out with his AppleScript. I just wanted to add that this is a Mac OS X issue, not an Isadora one. If you automatically startup -- for instance -- TextEdit, it also will be in the background and the Finder in front.
    In any case, I think J's script will help you do what you need.
    Best Wishes,
    Mark


  • Super thanks! I will try it out....


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.