• On OSX mtc event received by mtc receiver as well, but on windows not. Other software, such as Ableton Live, MAX/MSP, MIDI/OX etc. receive mtc events from this port as well (see attached picture). Why? I use demo version of your software.

    Isadora: 2.0.5
    Windows: 10
    MAX/MSP: 7
    Ableton Live: 9
    MIDI loopback: http://www.tobias-erichsen.de/software/loopmidi.html

  • Dear @egor,

    I have filed a bug report on this with your name on it. We will investigate.
    Best Wishes,

  • hallo. i have the same behaivior on win 7.
    normally i accept that isadora often is not usable for windows users, but some things should work if isadora will be a software which is sells for win.
    we use izzy since about a year very intensiv, but without multichannel audio and with so many differents (mtc doesn´t work, audio!, no minimalization for the gui without loosing the stage output, etc.) for win users, sorry maybe we have to search again for a usable plattform for us on windows.
    but back to problem, is there a solution for mtc input?


  • as posted in a thread near this one, here it seems working. Differences between my setup and yours is that i got no midi output eneabeled. Isadora just recive through midi loop and midiox  just send. Maybe you got a midi feedback issue, did you check it? 5b0685-mtc-isadora.png

  • Dear @deflost,

    Thank you for your comments about the Windows version of Isadora. I believe MTC to be working and will verify this by tomorrow. What you say about the stage window is true; the stage window is a "child" of the main window, and that means meaning that you cannot minimize the main window without minimizing the stage. We have a bug report filed on this and it will get handled.
    The issue of multi-channel audio is a larger one to face. Your comments help to reinforce the importance of this.. I think many people use Isadora primarily for video – even on the Mac, most people do not take advantage of the sound features. So we have not put audio capabilities at the highest priority. But your comments help us to understand the importance of this for some users.
    Best Wishes,

  • Dear All,

    Like @Maximortal, I have setup and tested MTC with Isadora v2.1 under Windows and it works properly. My test steps were as follows:

    This test uses the programs MIDI OX and MIDI Yoke. MIDI OX, among many other things it can do, will generate MTC. Midi Yoke is a "virtual" MIDI driver. It allows programs to share MIDI data by created 8 virtual input ports, and 8 virtual output ports.

    1. Install MIDI-OX and MIDI Yoke. (You can get these for free here: http://www.midiox.com/) You will need to restart after installing Midi Yoke. (Note: under Windows 8, I had to right click the .msi installer file for MIDI Yoke, and choose "Troubleshoot Compatibility" to get Midi Yoke to install properly.)
    2. Run MIDI-OX. Select Options > Midi Devices... to open the Midi Devices dialog
    3. Double click "Out to Midi Yoke 1" in the bottom left pane. "Out to Midi Yoke 1" will now appear in the top right pane under "Port Mapping."
    4. Click OK to close the Midi Devices dialog
    5. Choose View > MTC Transport to show the Midi Time Code Transport window. I used the default settings, but you can change the frame rate, accuracy and other settings here.

    Then, in Isadora...

    1. Open Isadora
    2. Choose Communications > Midi Setup to show the MIDI Setup window
    3. Under "Input Ports" on the left, set Port 1 to receive from "In From Midi Yoke: 1" so that Isadora will receive messages from MIDI-OX via Midi Yoke Port 1
    4. Add a MTC Reader actor to the Scene Editor

    Go back to MIDI-OX and

    1. Press the Play button on the MTC Transport control.

    Go back to Isadora and check the MTC Reader actor. You should see it reporting the MIDI Time Code from MIDI OX.

    Best Wishes,