assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

MultiMix Actor pixilation



  • I am working a scene where I have a picture image and a video clip feeding into the MultiMix actor.  When I play the video clip it becomes super choppy and pixilated.  I then reconfigured the path and sent the video to a projector and put the clip on a different layer and it play the clip perfectly.  Why does the MultiMix actor do this to the video clip?


  • Tech Staff

    I think it will be doing something with scaling but I'm not exactly sure. What size is your video and what size is your picture? If say your image is 1024768 and your video is 320240 then the video might be upscaled to match the image; but again I'm not too sure....



  • Please keep in mind: when multiple videos are being mixed together, they follow the rule set by the "When Combining Video" setting in the Video Tab of the Isadora Preferences. If this is set to "Scale to Smallest Image (Faster)" then all of the images will be scaled to the smallest resolution of all the videos being fed to the Multimix actor.

    In other words, if you had three videos – 1920 x 1080, 720x576, 320x240, the output would be 320x240\. This means that the 1920x1080 video, for instance, is being scaled down to 320x240 -- this can be very heavy on the CPU.
    You will get much better performance if all the videos are the same resolution.
    When you send the video to the Stage using a Projector actor, any scaling is done on the video card. So this is very fast.
    Hopefully that makes things clearer.
    Best Wishes,
    Mark

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.