Get image size actors



  • There are three actors that I believe all came with the current version of isadora for getting the dimensions of an image or movie file. They all seem to only output 2048 X 1536 or 0x0 if there isn't a file at the media index value that I select. Does anyone know why this might be happening or have a working actor?

    I couldn't find anything in the last few months regarding a bug report for the issue, apologies if I've missed it.

  • Tech Staff

    What OS are you running?
    I just took a look on Windows and only see 'Get Video Size'

    I have no trouble with it outputting the correct sizes for its input.

  • Tech Staff

    I have it. Meaning I get full functionality... all sizes @DusX.

    Sorry my first post was badly worded.

  • Tech Staff

    @Skulpture

    Do you mean that you have this behavior in an actor as well?


  • I'm running on osx. Mavericks I think? I finished the show I was working on and ive been too busy with other work to go back and look at this or the issue with user actors and ffgl. I'll do my best to get back to it tomorrow and give you some concrete details. Sounds like at least one of the image size actors may be third party. I know one is CI so I don't think you'd have it on the windows version?


  • Tech Staff

    Great, do let me us know..

    I suspected one might be CI, so I will test it next.
    Thanks


  • So I've created a little file with a scene showing the image size actors and another scene with a user actor that just has a projector inside of it. With the input of the projector connected to a user actor input.

    I think I was remembering incorrectly and there are just the two get image size actors. Both only display 0 x 0px or 2048 x 1536\. I also included a screenshot of the actors.
    None of the ffgl actors that I tried would connect to the user actor with the projector. I don't remember anymore which ones were 3rd party and which ones came with isadora, but I just tried around half of the ffgl actors I have, so I'm sure one would have worked if it was going to. Let me know if you want me to zip up my ffgl actors folder and send it over. Happy to do that if it'll help.

    bc087f-bug-test.zip



  • I thought I'd created a signature line, but obviously I hadn't. Now you have a little more info about my development machine.]

    EDIT: I just tried putting an intermediate actor inside of the user actor, before the projector and it seems to work just fine. I didn't spend hardly any time troubleshooting before, I was in too much of a hurry getting stuff to work.
    Tom


  • I'm guessing that the issue with user actors and ffgl plugins is probably the same as this thread: http://troikatronix.com/troikatronixforum/discussion/2069/ffgl-and-user-actor#latest so it's already a known issue, just a slightly different form of it.


  • Tech Staff

    I have seen the issue with connecting video within the User actors.. I am going to write up a bug report.

    My FIX was to go into the user actor for the Projector, and double click the user Input for the video, setting it specifically to vid-GPU
    (match property is not working, probably due to the mutability of those connections)

    That allowed me to connect the vid-GPU output of the FFGL to the projector (user actor).
    Something to remember here is that the Projectors video input is mutable. Meaning it will adjust to whatever type is connected to it. ( this page talks a bit about mutable connections: http://troikatronix.com/support/kb/izzy20-playback/ )
    This is great and very handly, **BUT**, mutability does NOT transfer thru User Actor inputs and outputs.
    These connections need to be decided on in the design of your user actor.  
     [ @mark please correct me if I am mistaken ]

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.