Exception Type: EXC_BAD_ACCESS (SIGSEGV) Exception Codes: KERN_INVALID_ADDRESS



  • Hi,
    after upgrading to 2.0 I can't use a project made under 1.3 without having crash with an "Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS". I removed syphon, reinstal Isadora and still having crashes. I can't understand where does the problem come from beacuse i'm not familiar with bug reports, maybe somebody can undesrtand where it can come from ? look like quartz composer (I resintalled xcode in case) or quicktime component problem but what ?
    thanks if somebody can help
    Samuel
    43ff37-sb-bug-report.rtf


  • Tech Staff

    Are you running the latest release.. 2.0.5?

    The error seems to be related to movie preload.. so I would look at areas of the patch that are doing this.


  • thanks for your help DusX, I'm running the 2.0.5 and don'y have a movie preload actor but in movie I have into ram on, I disabled it but it's still very unstable. When I select the first scene it take very long to show up, sometimes never. It was running fine in 1.3 but It wasn't possible ti redo all the patch in 2.0 but something is not working correctly and can't find what, maybe an actor that chenged between the 2 versions? I tried to simplify as much as I could but it's unstable and versy slow for something quiet simple.



  • I'm joining here new crash log If somebody understand it and could give me an advice… Scene is very slow to load, tried to copy paste in new scene but still slow. 361d4c-sb-bug-next.rtf



  • I just noticed something strange too: when I chose a video from my bin picker, it's not showing the right video, some bin picker ar working some don't.


  • Tech Staff

    This seems to be a system specific issue. 

    Please submit a bug report: http://troikatronix.com/support/isadora/
    We will be able to help you more efficiently thru our bug tracker, as well as, integrate any fix into the system more easily.


  • Thanks for your reply, I'll do it on next crash tomorrow. In the meantime I moved all my movies that where in my public folder to my main user home folder (I was using 2 user acount, that's why I wanted to have acces to my file with both acounts) it seems to helped a bit.
    all the best from Marseille


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.