assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Sending ASCII over serial



  • I am using send raw serial to send ascii to a camera controller. works from data viewer on a PC but Isadora seems to convert it to hex...

    Sending  the Words "Power Off" (which works from a pc terminal, it switches the machine off) gives me this output in the monitor:

    <- Serial | 1          | 50 6F 77 65  72 20 4F 66  66        | Powe r Of f         |

    So either its sending hex or its scrambled, both are wrong. So How can I send a clean Power Off  ?

    I am getting some feed back over serial, so I know she hears me.

    Thank you



  • Hi Fubbi,

    Have you tried with the classic send serial data ? The actor help explains how to send ascii I think.
    For the send raw serial, I guess you have checked the "mode" parameter. Are we sure this parameter is working properly?
    Hoping you're going good !
    Mehdi


  • Hi Mehdi!

    Well, I am working with TCP instead now, the setup changed here. Still having the same problem. I am seeing that the machine hears me, and I get some kind of garbled feedback. So I am pretty sure I am opening and closing my connection right, on the right IP and port.In the attached document there is a lot of chinese algebra about how to format the commands, but I can't seem to get the ascii going.

    The command to shut down, on page 21 is what I am looking for:

    ,2PCshtLF

    •  Shutdown the device (with Wake on LAN feature enabled): This command shuts down the device and enables the Wake on LAN feature by writing the value 2 (see next chapter for more information).

      Syntax :

      is the device index (0 for Master device, 1 for Slave device). 

      so dev in my case is 0 and LF is a line feed which is 0D in hex ( \n in isadora?)

      so how to format this for the send TCP actor?

      this does not work: "0,2PCsht" 0D

      and gives me this feedback

      <- TCP/IP | 192.168.1.70:10600  | 30 2C 32 50  43 73 68 74  20 0A    | 0,2P Csht  .     |

      -> TCP/IP | 192.168.1.70        | 54 50 63 6F  6E 30 2C 31  0D 0A    | TPco n0,1 ..     |

      so you see how the command is fragmented in the monitor (0,2P Csht), same as with the serial. I am doing something fundamentally wrong I guess...

      Fubbi

    6d851a-livecore_tpp_programmers-guide_for-v03-00-88.pdf



  • @mark what am I missing here? Thanks F



  • solved it! I was missing a carriage return! wohoo!


  • Tech Staff

    Can you post the working filter? It might help others to see the correct format.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.