assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Framerate going down when connected to beamer



  • Since long time I have this problem and now I want to try to get that fixed. I work on a 2 Screen-Computer, showing the stage on the second monitor in fullframe. Everything is fine. As soon as I connect my beamer and show the stage on the beamer my framerate goes massive down. Is there any different  scaling happening when the output is to the beamer that causes the problem?

    my video-files are 720x576px,
    my monitor 1366x786,
    the beamer 1024x768.


  • Tech Staff

    Each of your resolutions are different ratio's so scaling will be different from monitor to beamer.
    Also, you may want to see if your beamer can handle the scaling..
    You might be able to send it a stage size that matches your video files and have the beamer handle the scaling. But maybe not.
    If yes... you may gain much by offsetting some of the work to the beamer.
    I use XGA (1024*768) beamers often.. and at times I have used video at 1/2 that (512*384) since scaling it up to 1024*768 has low overhead. 
    Generally speaking the easiest on cpu scaling is even powers of 2, so 1/2 to full.. or 1/4 to full etc..
    Your mix of resolutions will require a bit more processing.. 


  • Dear niknaim & DusX

    @niknaim, can you tell us what version of Isadora you're using (2.0.5?) and on what platform.
    And then try this: go the Video Tab of the Preferences and turn on the "Disable Vertical Retrace Sync" button. Does that improve the situation?
    @DusX - I am wondering if this is vsync issue. Please follow through with this discussion and start a bug report if necessary. Thank.
    Best,
    Mark

  • Tech Staff

    @mark

    thanks for the pointer. We have been chatting about this in PM (he had technical issues with the forum)
    I will let you know what we find.


  • Hello Mark,
    I am on Windows and use 2.0.5. I tried "Disable Vertical Retrace Sync" but it didnt change anything. What I wanted to do anyway is to replace all CPU-actor by GPU-actors an now the framerate is incredibly stable! :)

    Niklas


  • Tech Staff

    Great... the GPU video process is amazing.



  • absolutely! Unfortunate I cannot find any replacement for my "displace" freeframe plugin. Also it would be amazing to change only the width of the video with the FFGL-panspinzommer.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.