assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

From 2 values, delay one of them...



  • ey people!

    In the configuration seen in the picture, I am dis/enabling an effect with a numeric value; 0 & 1, where 1 is enable off, and 0 is enable on.
    I would like to add a delay, but just to the value 1, so when "limit scale value" sends a 0, the 0 arrives immediately to "fx wave", but when "limit scale value" sends a 1, the 1 arrives 5 seconds later to "fx wave".
    I have been going around this in my head and cannot figure out how to do it... any suggestions?
    thanks!

    037fa3-untitled-1.jpg



  • Hi,

    if I understand right what you want to achieve, it is better to use an 'Inside Range' rather than 'limit scale value'. There you have trigger outputs for enter and exit and you can use these to easily trigger and/or delay like you want.
    best r


  • Thanks Reinhard!



  • lets see. I have a new complication: I attach an izzy file for the example.

    In the example, when "limit scale value" receives a value under 99, the bypass in "auto-fade" is on. When "limit scale value" receives a value over 100, after 2 seconds the bypass in "auto-fade" goes off.
    so far so good.
    now, there are some tricky situations in which the values change in the middle of a change of state in the bypass, which reverts this behaviour. And this, in my patch, happens very often. How could I prevent this???

    4f598b-untitled.izz



  • Dear,

    sorry, I don't get it. You want a value between 99 and 100 to switch something. If you set an inside-range-actor to min 99 and max 100 it will tell you exactly that. Your downscaling with a limit-scale-value-actor and feeding this into an inside-range-actor set to min 0 and max 0 does not make any sense. Try this - if the value is other than 99-100 you get a 0, if it's in you get a 1.
    best r

    c0741e-camilozk.izz



  • I understand reinhard, but this is not my problem anymore. I took away limit-scale-value-actor to try to explain my new problem in the new example attached.

    case 1
    -If I send an "enter" (from now on called "on"), the macro turns on
    -If I send an "exit" (from now on called "off"), after 2 seconds the macro turns off
    case 2
    -I send an "on", the macro turns on
    -I send an "off", after 2 seconds the macro will turn off
    -before this 2 seconds pass, I send an "on"
    In case 2, I would expect to have the macro "on", since the last signal I sent was "on", but because there was an "off" already on the way, that arrives after the 2nd "on", the final macro state is "off".
    how can I prevent this?

    59381b-untitled.izz



  • Hi,

    use a gate!
    best r

    1ae766-camilozk.izz



  • yes!

    I knew gate was the way, but the implementation was my problem.
    thank you very much!

  • Tech Staff

    @camilozk

    Attached a solution with a gate actor, as soon an on trigger gets sent the gate closes until a off trigger gets sent again.

    Best Michel
    f2dfc3-untitled.izz



  • same but more clever - that makes the difference between user and guru...


  • Tech Staff

    @Reinhard

    Thank you for the compliment.

    Best Michel



  • thanks!