assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Keyboard watcher with Makey Makey keeps triggering, there must be a simple solution



  • Hey Troikas and Tronix's,

    I'm struggling with the following:

    I want to connect a MakeyMakey to Isadora so that i can make a floor switch (two wooden boards with some coppertape and some foam).
    Now if I use a keyboard watcher (without MakeyMakey also) and i keep a button pressed down, the watcher keeps triggering.
    Is there a way to set it that it gives me 1 trigger and then stopt until it's been up again and then pressed again and just give me 1 trigger.
    I tried gates, toggles and other stuff but it won't help.
    There should be a simple solution for this but this guy (*points two thumbs to himself*) can't find it.
    thnx in advance.

  • Tech Staff

    @peppironi89

    There are sure several ways to acheive this, attached is a screenshot how I would do it. If you want you can file a official feature request that the keyboard watcher actor has a setting where you can set trigger always or once.

    Best Michel
    11755c-triggeronce.png



  • its a preference setting on your computer - you can stop it by setting the key repeat rate to off in the preference setting - it means in other apps you won't get keys repeating when you hold the key down a s well.

    picture from mac panel attached, its very similar in windows


  • forgot to attach picture 1a537d-key-repeat.png



  • Great! thanks guys! Very helpful!



  • By the way nick,
    Seems that windows doesn't have that off function, only very slow. 
    i'm a mac-man myself, but school has the Isadora licenses on windows... sigh...

    thnx tho



  • I use  Multi Blocker in different patches and it works fine for me...

    best
    p.

  • Tech Staff

    @gapworks

    Yes that helps in lots of situations, but if the switch is on the floor and the people switch something wile standing on the trigger and stay there it is hard to evaluate how long they are standing there, as long as they stand there they are triggering.

    Best Michel



  • Yeah I remember now on windows it is more fiddly.
    Its in the Ease Of Access Centre control panel (don't know if its still there in Win8 to 10).
    Select Make the Keyboard Easier to Use 
    Select Turn on Filter Keys. Click Set up Filter Keys,
    I think you need to click Turn on Filter Keys again on this page
    Select Turn on repeat keys and slow keys, click on setup repeat keys and Slow Keys
    Set how long do you want to hold down a key before it is accepted to 0, and select Ignore all repeated keystrokes
    That does it - although it is very fiddly to get the selections to be remembered - you have to click apply on every single one of the pages you have gone through to get the settings to stick


  • Hey guys,

    My installation was a succes! I left out the reactive tile and went with a wooden hand cut-out. it was way less fiddly.
    the gate of Michel dit the job.

    i've never heard of Multi Blocker, but as Michel said... It could have been the case that people would stand there for 5 minutes or even more, so that would be too long for multi-blocker. (as multi-blocker waits that long and it could also be the case that someone would walk away after 1 minute, another would enter within 3 minutes, then it wouldn't trigger)

    Anyhow, multi blocker stays in my 'favorites' list, it could help me with a lot of other cases.
    Thnx all!

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.