Unexpected Error - QC Plug-ins Won't Load/Izzy Won't Launch



  • I am in the middle of a show and all of a sudden while programming Isadora quit. I was trying to configure live camera settings. Upon restart, I get an error that Isadora has experienced an unexpected error.  Information: !(mQCFormat != _null) CCoreImagePugin.mm 239. When I hit quiet, I then get: "The QC plugin " " was not loaded due to unexpected error during initialization. IsadoraCore attempts to make all QC plugins available as Isadora actors, but some plugins may be incompatible. To prevent this error, please remove the plugin from your system." Unfortunately, when I hit OK, it just goes down the alphabet of all the QC plugins. I have tried trashing and reinstalling Isadora as well as running QC compatibility. Neither of these works. I tried trashing the QC plugins, but system says MAC OS needs them to run..... Completely lost. Any help?



  • Dear dansfine,

    This error started to crop up on certain machines running 10.7.4\. The 1.3.0f25 pre-release version has a fix for this error, but may not be totally stable in other areas. That being said, the file format for 1.3.0f24 (the release version) and 1.3.0f25 are the same. So, if you like, you can rename your current copy of Isadora to "Isadora 1.3.0f24" and then install 1.3.0f25 to try it out. Just make sure to **drag** your files to the app instead of just double-clicking, otherwise you can't be sure which of the two copies will load the file.
    Please see the topic "Isadora 1.3.0f25 - Preliminary Release" in the Announcements section of this forum to get 1.3.0f25.
    Best Wishes,
    Mark


  • Thanks for the reply Mark. I've tried the install with 1.3.0f25, but the QC plugins still will not load. The only things that have changed since this all became an issue are:

    -I am sending an OSC signal from processing into Isadora. (worked for hours without crashing)
    -When Izzy crashed I was trying to setup a live camera feed - via a blackmagic capture card. (blackmagic pci card only reads my inputs as 1080i 30 or 60 and in Isadora it shows all other blackmagic capture settings but 1080i 30 or 60. Not sure what the problem here is)

    So, now I cannot access any QC plugin. I wonder if there is a conflict somewhere.  I am running Mountain Lion.

    Cheers,
    Dan



  • I was able to solve the problem. Seems that it was actually a hardware problem causing a major conflict with QC plugins. I need three displays out of my mac pro and thanks to Apple in order to use all three outs on the video card, you need to have one thunderbolt out with no adapter on it (forcing one to buy an apple display?) So,I was using a Gefen USB to DVI adapter (which I had successfully used in Isadora before on a different computer) - which it turns out was the problem. When it is plugged in, it creates all sorts of crazy conflicts, not only with Isadora, but also Processing. Basically locking up the QC in the core video processing on the CPU. In the lack of sleep of tech week, I had stripped the computer of all external hardware except the Gefen. Once that is out of the system, everything works again. I tried a j5create usb2 to hdmi, but that froze QC plugins as well.



  • For the record, these USB to DVI adapters are notoriously problematic. They do not implement the full OpenGL spec, which causes havoc with anything having to do with Quartz Composer and/or Core Video plugins. So, if you want to use QC/CI, you need to stick to the "real deal,", meaning a proper graphic card with a GPU. (Which I believe such adaptors do not have.)

    Probably I should buy one of these and see what OpenGL features it reports (if any) to find out how I can avoid these problems in the future by alerting users to the potential problems.
    Best Wishes,
    Mark


  • Mark, on a related note are there any issues on a Mac Pro using DVI to VGA for output to a projector?  I havent noticed any that I could attribute to that, but are there any advantages to using a different interface?  Thanks.

    eric

  • Tech Staff

    @eric

    There shouldn't be any problems on a MacPro using DVI to VGA.

    Best,
    Michel


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.