Video Mixer / toolset ALPHA Release

  • I tried again. Got this error.

    No error with f25 but no image on output either. Clicked few places but did not go into too much. What would be the first steps to run this?
    BTW got FF working by reinstalling(replacing the folder) Pete's plugins. I have not used these for some time(years) so these may got corrupted somehow.


  • Tech Staff

    Thanks for the screen grab. Can't say I have ever seen this error before, but perhaps other Mac users can shed some light on it.
    I am happy to say that for the most part the Interface looks about right (some minor font issues.).
    I will write a short, "getting started" post in the next day or 2, but once it runs you basically have to select a video in the bin, then the channel number that it outputs on, and at the least set a Projector to use that channel as an input.
    In this way you can route the video stream thru any of the modules. Data values work in the same sort of way. Best place to start there is with the LFOs.

  • Actually this runs with f25 so far OK. No errors.

  • Tech Staff

    So glad to hear that. Gives me hope that getting it running on windows f25 should be fairly straight forward.
    I know a few modules have minor problems/inconsistencies but any reports would be much appreciated.
    I hope that you have some fun with it. I also hope for a wishlist of features/modules to add. We all like to do different things. Due to the 999 limit for link Ids I will have to remove duplicate modules to allow for more variety. This will of course make for a more complete 'framework' but will impact the pre-made mixer.. I am thinking I may maintain both separately, once I am able to save the framework actors in an external library (I ran into an error that prevented this that I haven't gone back to test again yet.)

  • Regarding the error -- it's from the Float to Integer actor. I'm a bit mystified how this can happen... it would have to be while the patch was being initialized, i.e., when you jump into the scene.

    Vanakaru, what version of Isadora were you using when you got this error? (You say it runs fine in 1.3.0f25, right?)

  • @mark yes f25 is fine but as DusX suggested f24 gives the error.

  • Tech Staff

    I suggested f24 because that is where I developed it (on Windows). I still have no luck running the file on f25 windows, I can open it, but can't move into the 'main' scene, it just hangs Izzy.

  • Dear DusX,

    Is the patch that freezes on Windows the one included above? I'll look at it if it is -- but please file a formal bug report so I won't forget. (My show 'loopdiver' opens in Berlin next week, so my focus is not totally on Isadora at the moment.)
    Best Wishes,
  • Tech Staff

    Yes Mark. The way it happens is as follows:
    1. open patch.
    2. scene 1 is loaded.. shows FPS etc..
    3. click button to Proceed (big button)
    4 hangs.. never reaches the 'Syst3m' scene.

    I will add a bug report ASAP.

    best of luck with your show.

  • Tech Staff

    Just wanted to ad that I have had a chance to test on Mac running F25, and the patch runs beautifully, other than a few small and very manageable font issues.
    I have identified a few issues with initial values not loading into channel selectors, but simple selecting the required channel again will correct the problem.. and the top 'active channel' indicator strip works, so you can always peak at it.
    In any case, I am happy to see it working on Mac, and plan to continue with improvements soon, including a short getting started video.