Isadora 2.x won't install on a new machine



  • Isadora 2.x won't install on my new PC. The PC is running Windows 10 and absolutely has the hardware specs to run izzy but the installer just hangs. I own a USB key 2.x license so I downloaded the 2.1 Windows USB key .exe installer file. 30MB, double click on it and...nothing. Nothing comes up, no process in the task manager, no application, no installer, nothing. When I try to delete the .exe I get a "The action can't be completed because the file is open in System" File in use error. It takes several system restarts for the .exe to finally release and let me delete it. I've tried both the 2.1 and 2.05 installers and neither one is working.

    I'm at my wits end here, all I want is to get my izzy installed!

    Any help would be appreciated.


  • Tech Staff

    I have never encountered this.
    Only thing I can think of is that you might have a service that runs that interferes with this install.

    So try shutting down all background services that are not core, before trying the install.
    Do you have Sony Vegas? This was a problem for one user. (not sure why)


  • try getting a 1.x version installed and then uninstall it. then try 2.x. I think I had some similar hurdles at some point with when the machine froze during install(freeze unrelated to setup process). I think I had to delete some files from the user/"user/appdata folder, but I forget the steps I took to fix it.



  • @DusX
    I don't have Sony Vegas installed on this machine. I'll try killing background services and then run the installer again. I'll report back.

    @LPmode
    I'll give that a shot as well, this is actually the first system of mine that I'm trying to install a 2.x version on first. All other systems that I've used I've had a 1.x install on before upgrading. Again I'll report back!

    Thanks guys, if anyone has any more suggestions please send them my way!

    -Cheers



  • Fixed.
    Also I am a COMPLETE moron.

    I tried the solutions you suggested and nothing worked although I was able to install a 1.x version without issue. I was starting to wheel out the various anti virus/anti malware programs I use to scan my system and more specifically my registry when a thought occurred to me: Most of those programs I use are one off scanners...all save one. Avast is my always on antivirus. It was still running. I had not yet tried to disable it and then install. So I restarted my machine to release the installer processes again, disabled my Avast, double clicked on my 2.1 installer and...BAM the installer ran flawlessly and 2.1 is up and running.

    So two things to take away from this.

    1. I'm a moron, the anti virus is the first thing I should have checked and the most obvious solution. Isn't it always the simplest things that trip you up the most?

    2. @mark the 2.x USB installer .exe files are blocked by the Avast antivirus program. The 1.x installers are not, don't know if that's something on the Isadora programming end or on the Avast end but just giving you a heads up. Easy workaround is just disable all your Avast shields before you run the 2.x USB installer .exe files. I didn't try it with the non USB 2.x installer files so I don't know if they have the same issue.

    In case its relevant for tech support's benefit here are this system's specs:

    Windows 10.0 (Build 10240) 64-bit

    Intel Core i7-5960X @ 3.00GHz

    32GB RAM

    NVIDIA Quadro K4200

    Isadora Version 2.1 USB

    Avast Free Version 10.4.2233

    Thanks for all your help everyone and I hope this thread saves someone else a headache or two down the road.

    Cheers!


  • Tech Staff

    Sorry that you experienced this.

    You are not a Moron. These things happen. But you are right; this thread ill no doubt help someone in the future so sharing is caring.
    Glad you are sorted now.


  • First, @DMacur -- you're def. not a moron. This is our problem, not yours!
    @Skulpture and/or @DusX,

    Can you follow up on this and file a formal bug report? This should not be the experience user's have when installing Isadora.
    Best Wishes,
    Mark

  • Tech Staff

    I will do.

    @DMacur these things are easy to forget. I should have brought up anti-virus right away as well.. sometimes we start thinking big picture, when the issue is a small thing right in front of us.
    I'm glad you have it running now.


  • Is it allowed, and if so how is it possible to unregister an Isadora license on one computer so that that license can be used on another computer?

    --For example when you are getting rid of an old laptop for a new one?

  • Tech Staff

    @atrawickb

    each license comes with 3 registrations available, for exactly this purpose.
    "Our registration scheme is a bit unusual in that there is no de-authorization procedure. 
    Instead, should you need to register Isadora on a new computer, you simply generate a new registration code for the new machine. 
    You may do this up to three times per year for each license you have purchased."

    More details here: http://troikatronix.com/purchase/licensing/


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.