assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Smooth transition between two scenes


  • Beta Gold

    Hello

    For a project I need to do two different kind of transitions between two different scenes.
    I feel like I already did it before without any problem, but some how I can make it work properly now...
    1- Changing from one scene to another with the same image. I can't make it work without a little black image in between.
    I guess my scene is a bit too heavy, I tried using "Preload scene" actor, but it won't make any difference...
    That's why I thought dealing with it the same way than for my other transition.
    2-Crossfading between two scenes.
    I tried doing that by using two "activate scene amount" cross fading (the current scene fading out only until 1% to make sure it's not deactivated before the jump).
    But when I jump to the next scene, it is automatically deactivated, and there's nothing I can do there to change this, besides going to another scene and coming back.
    I've worked around to find out a solution but making this more simple for testing and it's doing the same.
    I create 2 scenes with one movie player and one projector.
    I go to the first one and create a "Activate scene amount" actor. Whatever the amount I put in (besides 0), when I manually go the next scene, it gets deactivated.
    So I guess my problem is that i'm misusing the "activate scene amount" actor.
    What I want to do is so common, I'm sure somebody has done it before.
    I'm using for the project a Mac Mini with 10.10 and Isadora 2.05, I tried on my Macbookpro 10.10 with Isadora 2.1 and it's acting the same

  • Tech Staff

    Can you make it work in a new simple Isadora file? Just the scene fade.


  • Beta Gold

    @DusX the fade is working but when I jump into the new scene I just activated with the fade, it gets deactivated


  • Tech Staff

    Can you post a screen grab or better yet the sample patch?


  • Beta Gold

    @DusX you'll find attached 3 pictures of the three steps for the simple test which is not working
    1/ video active in scene 1 with scene 2 unactive
    2/ video active in scene 2 with scene active as well (50%)
    3/Jumping to scene 2 makes it unactive

    And a patch with what I wanted to do as a crossfade btw 2 scenes
    4e873a-capture-decran-2015-12-05-a-16.34.36.png cd0015-capture-decran-2015-12-05-a-16.35.14.png 9534b0-capture-decran-2015-12-05-a-16.35.40.png 4af8a1-crossfade.izz



  • @Maxime

    The primary scene (bright blue) will always be deactivated when you leave it. There is no way around this.
    But, if you make a "control scene" that uses two Activate Scene actors – one for each of the Scenes you wish to activate – then you can fade either of them in or out as you like.
    That's the only solution I can offer.
    However, I am troubled by the "black" glitch you get between scenes, even with the Preload Scene actor. I would file a bug report about this, because that should really not happen if you are using the Preload Scene actor.
    Best Wishes,
    Mark

  • Beta Gold

    Thanks @mark for these informations

    I'll investigate a bit more next week about what can cause this black frame and keep you updated.


  • I have the same problem with a black frame between scenes.  I seem to have solved it by setting "play start" in "movie player" to .001 percent.  That's such a small number that it doesn't effect the beginning of the video visually.  I suspect that there is a problem with the h264 compression.  I've been doing compressions directly out of After Effects, and I've recently read that it's much better to compress in other software -- like Adobe Media Encoder, Final Cut Compressor, or Quicktime Pro.  Haven't tested that yet.


  • Beta Gold

    Thanks @lamb1847 I'm going to try all these things!

    I thought I could be due to the fact that I'm routing two Syphon feeds in that scene, but even by removing it, it still act the same....
    I attached the sample of the patch, in case someone find an obvious mistake

    066f2a-scene-change.izz


  • Beta Gold

    @lamb1847 it didn't work for me in the end...

    I've finally managed to locate where the problem is coming from in my patch.
    On my second scene, I have several video mixer connected in row, especially one which is located in a "fade out" user actor.
    If I remove this actor from the chain, I have no problem anymore....
    Is it a known problem by chaining several video mixer?

  • Tech Staff

    @Maxime

    There isn't any known issue with chained video mixers.
    Can you describe the setup that causes the issue, so that I can try to reproduce it and confirm if it is a bug?

  • Beta Gold

    Hi @DusX

    I'm trying to jump from one scene from another which have the same image without having any cut in btw.
    My scene could be a bit heavy, so i'm preloading the scene before jumping and I deactivated all movie players that are not in use right away when I enter the scene so I have only movie players visible but on pause. One video is 1280x720 the other one is 1000x1000.
    I have also 2 syphon feeds in it which I can't do much about unfortunately.
    When I'm jumping from one scene to the other, I always get very quick black frame when entering the second scene.
    I tried to activate the second scene and stay on the first, I still get this black frame when activating the second scene.
    So I tried removing some actors from the second scene, one by one, to see if it would make any change and I found out that by removing one user actor I did I didn't have problem anymore. It's a very simple actor with a video mixer and envelope Generator to fade out the video. I have another video mixer after, which is acting as a master intensity which is not causing any problem.
    The mac mini I'm using (X.10 with SSD Isadora 2.0.5) is projecting on the floor and the back of the stage with 2 similar chains of actors in the scene, towards to different projectors. I get the "black frame" on and off in a very synchronized way on both projections.
    Maybe I try to take out my fade out of the user actor just to see, even if doesn't really make any sense
    (The 2 scenes of my patch are attached in a previous message)

  • Tech Staff

    @Maxime

    It's a very simple actor with a video mixer and envelope Generator to fade out the video.

    I can imagine that if you have entered the scene before and the envelope generator for example goes from 100 to 0 that the moment you re-enter the scene the mixer has the last value "0" for a micro second until the envelope generator starts counting down from 100.

    Try setting the initialize value of the "mix amount" to the starting value you are wanting.

    Best Michel


  • Beta Gold

    @Michel I'm already initializing the actor with the value I want, and I have same system on other video mixer without any problem...

    Only difference is this one is in a user actor while others are directly in my patch...

  • Tech Staff

    @Maxime

    Maybe you should publish the "mix amount" input of the mixer and initialize the wanted value with from outside the user actor. Does this help.

    Best Michel


  • Beta Gold

    Thanks @Michel I'll try that!

    We're playing next time in one month but i'll give it a try and keep you updated, thanks again


  • I did a test with a H264 compression done with Adobe Media Encoder, using best quality and two passes.  I have no black frame anymore between scenes.  So in my case I think the problem was using H264 codec generated by Adobe After Effects.


  • Beta Gold

    Old Thread but could finally try it

    Thanks @Michel , that was it! It is now working perfectly!

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.