3D line



  • Hello,
    since i want to get started with woking with 3-lines I tried to rebuild Grahams tutorial. https://www.youtube.com/watch?v=TE2-TLasdSg
    As I foud out in isadora 2.0 i have to work with "virtual stage" instead of the "3d renderer". But when I change the y-axis for exemple the 3d-object seems to turn around with a very large radius, so it leaves the stage, actually this happens whatever axis I turn it around.
    Cn anybody explain me the behaviuor and how i can get to turn the object around itself?

    Thanks,
    Niklas


  • Tech Staff

    @niknaim

    I see what you mean, the only solution I see is double click the eye symbol next to the projector actor title, tick mark 3D enable and all the 3D inputs you want to have on the projector, after clicking OK you will have additional inputs, enable 3d and now you can do what you would like to do.

    Best Michel



  • Hi Michel,
    thanks for your idea. It goes in the right direction. But itsnot bpossible to see the backside of the lines.The lines dissapear if they are shown from the backside...

    Greetings,
    Niklas



  • ... and, a stragne thing, the motionblur, taht i connected between the stage renderer and the projector has no effect anymore, if I turn the lines within the projector itself.


  • Tech Staff

    @niknaim

    You also have to tick mark the "render back" in the Projector "eyes" settings to see the back of your 3d image.

    It is not strange that you do not see the motion blur because you manipulate the 3d postion after the motion blur effect, so there does not go any motion through the motion blur actor. What else can you do:

    Use the 3D Projector instead of the Projector, set it's destination to renderer, stage/channel to 2 and render back to on.

    place another virtual stage that listens to channel 2, put a motion blur after it and a normal projector at the end.

    Now if you manipulate the 3d objects position with the 3d projector it gets passed through the motion blur at the end.

    Best Michel

    dff17b-3d-projector.png



  • Hi Michel,
    thanks for your idea. But I unfortunately I dont get it to run.
    As soon as I connect the 1. (left) virtual stage to the 3-d projector, the destination and channel/stage input greys out and I cannot set it to to stage 2anymore. Also I see that that virtual stage doesnt grey out the stage-input as it does in your screenshot. The 3rd difference is that my normal projector (on the right side) greys again out the stage-input. Do you have any idea what makes it react different in my setup?

    About your explanation of course you are right, the motionblur I had at the beginning is of yourse before the rotation and cannot work. Its not strange :)

    Niklas



  • ... 0ac82c-3-line_2.jpg


  • Tech Staff

    Sorry I don't have any suggestion for this at the moment. I would like to ask @mark to take a look though. The chaining of 3D rendering actors is interesting.



  • ok, thanks.
    Just because we are talkimg about the 3d-renderer. I am also experimenting with multiple turning shapes, that have an solid outline and a transparent filling. They seems to delete each other in a way when they are overlayed. The same happens when I use the normal projector with enabled 3d.
    398026-3d-shapes-overlay.jpg c4b277-3d-shape.izz


  • Tech Staff

    @niknaim

    Did you download the latest Isadora 2.1 version, you are talking about 2.0 in your first post?

    Best Michel



  • its all on version 2.1.



  • what I ment in my first post is "beginning from 2.0" I needed to use the virtual stage.



  • ok, I think I got it.I deslelected on the "shared OpenGL Resources", and now the lines are working. I had set it off to use 2 stages, which didnt work before with it selected.



  • ... but  the shape-overlay problem stills happens as you can see in my posted file 3-d shape.izz


  • Tech Staff

    @niknaim

    Ok I see what you mean, you have to switch the "depth test" to OFF, this should solve your problem.

    Best Michel



  • Thats it. Sorry, I am new on that 3d-actors. Thanks a lot and have good new year!


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.