5 movies to 5 projectors



  • I am trying to send 5 movies to 5 projectors and not getting the consistent frame rate I am looking for. it fluxuates between 10 and up to 27, the play is jagged, the movies appear to stutter. These movies are all 1280 x 720. I edited and compressed them in finalcut, they are all the same length and synched so it is important that they play at the same rate/time. This is the 4th try with different codecs. The last time I used Share>Master File> Format: Computer, Video Codec: H.264 faster Encode, Resolution: 1280 x 720. When I hover over the clips in the media window they have the codec: avc1.
    I have updated my computer to a 1T SSD drive and have 16 MB of RAM. nothing else is on. I have 4 NVIDIA GeForce 7300 graphics cards. The projectors are of different sorts two HD MItsubishi short throws and an HD in focus, as well as two older panasonic, which does not have the 1280 x 720 option so those images go out as 1280 x 960 which I would think might be what is slowing me down except that even before I send out to the projectors the frame rate is inconsistent. Is there a different codec I can try for smoother play? Any imput would be appreciated.  thanks S.



  • without using Isadora at all, I can open the clips all with quick time on the main computer desktop and play them all move them out to the projectors with no loss of speed, but I can't press play at the same time.



  • Dear @sbickford,

    You gave us most of the details we need, but a few important ones are missing:
    1) Are you running Isadora on Mac or Windows?
    2) What version of Isadora?
    3) What version of the operating system?
    4) If you are running 2.x, have you purchased the 2.0 upgrade so that the 2.0 features are enabled?
    If you are running on Windows, you'll likely get far better performance with the HAP codec (see [here](http://vdmx.vidvox.net/blog/hap)) or by compressing the movies as WMV or AVI so that they can be played natively under Windows OS. If you are running on a Mac, you should also try Apple Pro Res 422.
    Also, it you should check that the bandwidth of the five movies is not too high. Please review [this forum post](http://troikatronix.com/troikatronixforum/discussion/2061/helpful-document-on-h264-compression-bandwidth).
    You said that you have four NVIDIA Graphics cards. Does that mean you're running on a desktop machine?
    I can tell you that I'm playing 5 x 1920x1080 H264 Movies on my Mac Book Pro and it's running super smooth. Not quite the same as when you have real video projectors connected, but still it's super solid and the "cycles" value is quite high.
    One final test, go to Isadora Preferences > Video and check the box that says "Disable Vertical Retrace Sync." Does that change things?
    Best Wishes,
    Mark


  • RE "I can open the clips all with quick time on the main computer desktop and play them all move them out to the projectors with no loss of speed, but I can't press play at the same time."

    while you are sorting Isadora you can pre-check the movies themselves to see if they do play through properly, and get them all to play simultaneously, with Quicktime Pro, using the Command+Return key to stop or start all movies.

    mike

    607d18-qt-play-or-stop-all-movies.png


  • Tech Staff

    I am testing a few different setups with 5 videos running to 5 stages. (all files running from SSD)
    All my test files are 1080p, 30sec clips. And have timecode as part of the video footage. Tested on MacMini

    MOV (using h264), I can run 3 at 30 FPS
    MOV (using ProRes422) I can run 4 at 30 FPS
    MOV (using ProRes422) I can run 6 (to 6 stages) at 30 FPS and high cycles.
    HAP runs best for me on both platforms (as long as you have fast enough drives)
    Additionally, if I leave the scene and re-enter (to start playback of all players on enterscene) 
    and let the files play for a bit, then pause playback, I can see all my timecode is in sync.
    Other people (Mark for example) have reported better performance with h264, and Prores. I feel like there is something to getting the settings right with these formats. I haven't had great luck.
    Hap is very easy to compress to. Its either standard, High Quality, or with alpha (I used standard for these tests).


  • Mark,
    Oh yes, each of these clips are just over an hour long.
    I have a Mac, OS 10.6.8, the new version of Isadora 2.1 I purchased the upgrade, yes running on a desktop computer, I will check the "Disable Vertical Retrace Sync.", and the Apple Pro Res 422 codec. How does one check the bandwidth? Thanks so much for your help folks! I'll get back to you. For my studio showing tomorrow I can use the quicktime pro fix that is awesome.
    S.



  • Dear @sbickford,

    Well, I would say that 10.6.8 is the problem. The newer playback system offered originally in 10.7, but much more mature in 10.9, is called AVFoundation. Isadora uses this automatically if the operating system supports it. If not, it falls back to the older system, QuickTime. But QuickTime offers poor performance for H264\. You'll have much better luck with Apple Pro Res tho. Try that codec instead.
    You won't have to check the bandwidth for APR... only H264\. You can check the bandwidth by choosing the "Show Movie Inspector" option in QT Player.
    Best Wishes,
    Mark

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.