Video playerback in v2.1 and greyed out options and texture projectors



  • Hello,

    I can't get the video player to play videos in Isadora 2.1, the play won't let me choose a stage either.

    I also can't find a "texture projector" actor anywhere.

    My projects made before I upgraded all work fine in the new version. I'm really confused why I can't get the newer actors to work.

    Thanks, Kedar



  • ok so i found if i toggle the slider on the optimize function on the movie player between performance and interaction then the video starts to play.

    Does this happen to anyone else?

    i guess the "texture projector" was a temp name and now its just "projector" :/



  • You can view the Texture Projector by un-ticking this box in preferences: 6b8d14-screen-shot-2016-02-03-at-09.14.36.png


  • Tech Staff

    @Klawrence

    Yes it is possible that the movie you want to play does not play in performance mode but in interaction mode. Interaction mode uses the old quicktime playback enginge and the performance mode uses the new AVfoundation playback engine.

    With Isadora 2.1 you get back the functionality to set the stage number on the projector side.

    The texture actor is still available if you follow @Skulpture screen grabs. But it is wise to not use them to make you patch future proof. The just "projector" actor is the way to go.

    Please read the following article about the new movie player, this will help you understand how it works: http://troikatronix.com/support/kb/izzy20-playback/

    Best Michel



  • Hi Michel and Skulpture,

    Thank you for both of your help. I was confused by the graphic of the movie player in article regarding the player and video formats because it has a number 1 on the stage setting.

    I was looking the texture projector because a tutorial said to use it but yeah I'm going to go with the "projector" actor like you suggested.

    For me the "movie player" actor plays my video in both interactive and performance modes but the videos do not automatically start when in performance mode. I've only tried with photo Jpeg compression on the video files though. Its all good, I prefer the interactive mode anyways.

    Thanks again, Kedar


  • Tech Staff

    @Klawrence

    What tutorial was it that mentioned the Texture Player?
    It should be updated.


  • It was the one under the knowledge base section.

    http://troikatronix.com/support/kb/izzy20-playback/

    Support < Knowledge Base < Quick Start: Movie Playback


  • Tech Staff

    thanks


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.