[SOLVED] Izzy keeps crashing



  • Hello Izzy professionals,

    I do have an urgent issue. We do have rehearsals today for a big show in New York and I did a complex patch that recently started crashing immediately if I try to open it or some times with a delay if I try to change anything.

    It is strange, as even older versions that I saved with the autosave do show this behavior, but only to a certain state. But these and the last version did work fine yesterday!

    Another strange thing is, that a second version on a separate system that was edited in a different way from a certain point (different branch) does show the same behavior since today!

    I did change it from 2.1 to 2.2, but that was in a early state and worked fine so far!

    Is there anyone that could help me getting into that!?


  • Tech Staff

    @DillTheKraut

    I sent you a PM.

    Best Michel



  • Ok,

    I think I found it.
    Deleted some user actors with Global Data Actors.
    Seem to be stable at the moment. Need to change the get actors to get the patch working again.


  • @DillTheKraut,

    I just sent you a PM also. Please send me the crash reports as I instructed. But also file a formal bug report please, otherwise this issue won't get tracked.
    Best,
    Mark


  • Dear All,

    I wanted to add here that there was a feedback loop in the patch that was causing thousands and thousands of lines to be added to several Data Array actors. I have supplied @DillTheKraut with an analysis of this problem so that the patch can be updated to address this. Hopefully this will lead to the resolution of the problem.
    Best Wishes,
    Mark

  • Tech Staff

    This post covers the usage of the data array, in some detail.

    Very likely useful: http://troikatronix.com/troikatronixforum/discussion/2585/data-array-actor-keeps-editing-in-deactivated-user-actor

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.