• Hi all,
    I'm experiencing almost same behaviour with my macmini under osx 10.9.5.
    Izzymovieplayer64 endlessly crashes at Isadora launch.
    In activity monitor, ReportCrash is eating 180% of my processor.
    I remember I had codec issues which crashed IzzyMoviePlayer, with Isadora 2.0.5.
    At that time, Mark helped me a lot and found the culprit.
    But since in my actual configuration, Isadora 2.1 is working great, and Isadora 2.2.1 is crashing, I don't think it's the same codec issue.

    Thanks for the hard work.



  • Here's one of the multiple IzzyMoviePlayer64 crashlogs :


  • Beta Platinum

    Also Report Crash is on Top of the Activity monitor, I get also the fans running high

  • Beta Platinum

    Here a screenshot b7c645-screenshot-2016-03-24-14.42.47.png

  • Dear @crystalhorizon, @dbini, @fredvaillant, @fifou,

    Can each of you verify you are on 10.9? I'm getting the feeling this is a 10.9 only issue. If that's the case I'll get a fix out as soon as humanly possible. But please each of you let me know.
    In the meantime, to alleviate the problem for you all, please download a copy of v2.1 and install it after renaming v2.2\. Then right click v2.1 and choose "Show Package Contents." Go into the Contents folder and then into the Mac OS folder. Copy IzzyMoviePlayer64 and then, after opening the same sequence of folders in v2.2, replace IzzyMoviePlayer64 there.
    In v2.2, there were bug fixes in these background Movie Players that allowed them to work again with 10.8, but obviously this has adversely affected 10.9.
    I'm very sorry that we let this slip through. I will see that it is corrected within the next 24 hours if at all possible. Thank you for your patience.
  • Beta Platinum

    Yes I am on Mavericks 10.9.5

  • Yes I'm on Mavericks 10.9.5.

  • Hello Mark,
    I just sent you by email the 2 crash report below. I had 8 reports of IsadoraCore and 4 of IzzyMoviePlayer.


    As you asked, I just changed in v2.2/Mac OS folder the izzyMovieplayer64 and for the moment it's very calm...
    So maybe the problem is solved.

  • Dear Mark

    I forgot to answer to your question about the Movie player optimize set, I quickly did the test patch and I had no image out of the Movie Player (red link an nothing on stage) with performance and I had one with Interaction with appleprores. Don't ask me why, I have no problem today... What I still have is with the video in watcher, when I start the Live input, I need to leave the scene and go back to have my live input on my stage.

  • Yes Mark,

    My MacMini runs under OSX 1.9.5

    The IzzyMoviePlayer64 file replacement works great !


  • Mark,

    It seems to work great.
    But as I was testing the "new" movie player, I noticed that there is no loop end trigger in performance mode (AVFoundation). With the same movie (.mp4 - 720p - x264 - AAC audio) in interractive mode (QuickTime), end trigger is launched as usual..


  • @fifou,

    Thanks for joining the testing team. ;-) I will look at the 'loop end' trigger problem right now.

  • I just noticed that Chimerik already pointed that issue in this post :

    Thanks Mark.


  • **[EDIT:** the attached app now fixes the 'loop end' trigger bug mentioned by fifou about.**]**

    Dear @crystalhorizon@dbini@fredvaillant@fifou,

    Please install the attached version of IzzyMoviePlayer64.
    1. Right click on the Isadora application and choose "Show Package Contents..."
    2. Go into the Contents folder and then into the Mac OS folder
    3. Delete the existing IzzyMoviePlayer64
    4. Place the attached .zip file inside of the Mac OS folder, alongside IsadoraCore and IzzyMoviePlayer32
    5. Unzip the file so that IzzyMoviePlayer64 appears there
    6. Delete the .zip file
    This updated version works for me on 10.9\. I am giving it to the team for testing now, but I wanted you to have it immediately.
    Please let me know if it works for you, and thanks in advance for a speedy reply.
    Best Wishes,


  • Works great !
    Tested with a full HD x264 .mp4 file. The end loop trigger is sent as usual, in both interactive and performance mode.
    But the 4 IzzyMoviePlayer32 and the 4 IzzyMoviePlayer64 are shown in red (not responding) in the activity monitor. Even when they are running (using % processor).. I don't know if it's a normal behaviour..

    But it works great !

    Thanks Mark.


  • Dear @fifou, RE: this

    "4 IzzyMoviePlayer32 and the 4 IzzyMoviePlayer64 are shown in red (not responding)"

    Yes, weirdly Activity Monitor shows these background apps as "not responding" but  they really are. (I researched this at one point, and it's some kind of operation system weirdness, not really an error in the apps.)
    Sounds like you're good to go. I'll wait to hear from the others.

  • Yes it works for me too. What is the difference between the one from v2.1 ?

  • Dear @fredvalliant,

    I made several improvements to IzzyMoviePlayer64 for v2.1\. But those improvements led to problems for user who still use Mac OS 10.8 – problem similar to the one you identified in 10.9\. So, we worked with those users and solved the problems for v2.2, but I introduced a bug for 10.9 users. (The biggest problem is that some function calls available in Mac OS 10.9 are _not_ available in 10.8; this requires doing things differently depending on the version of Mac OS that is being run.) 
    I must embarrassingly admit that we simply missed the problem I created in 10.9, the one you identified in this thread. I apologize for the hassle and thank you all for your patience.
    I will post a "hotfix" as soon as the team verifies the installer, etc. In addition, for future releases, we will implement a more extensive beta program to ensure that builds are getting run on 10.9, 10.10, 10.11, etc. This should allow us to prevent such bugs to get out to the public in future releases.
    Best Wishes,
  • Tech Staff

    I can report, that this fixes the issue for me as well.

  • Hi Mark, no problem for this first meeting with v2.2. We know that we upgrade when we're not on stage and v2.1 wasn't crap.

    I'll dive in this new version and in few weeks I need for a next project to buy a new computer and it'll run with Capitan.