[SOLVED] Movie Player Plays Even After Enter Scene Trigger Sets Speed to Zero

  • Hi,

    I need some help solving a buggy issue. I am creating an installation which consists of five picture frames and images mapped within each frame. I have set up each scene so that on entering there is a timer and comparators, when certain values are reached it triggers the trigger actors, and in turn movie players.
    The problem I am having is that exactly 50% of the time the movie players will play even if the speed value has been successfully set to zero (i.e. displays "0" but the clip is playing and visible).
    Has anyone run into issues like this? and have a solution? 
    I am building the project on a windows machine but hope to run it off an old 2009 mac pro.
    Clips are exported as .mov using hap codec.
    I have latest izzy 2.2
    my rig runs win 10 64bit
    intel i7 6 core
    dual gtx 970 in sli.
    64GB ram.
    most scenes are fairly similar to attached pic.
    (maybe my workflow is crap... then I would dearly love some advice on that)


  • Why you dont use "Initialize" (clicking on the entry name, you open a window where you tick on initialize and choose the value).

    With that I have no problem entering a scene.

  • Dear @tim_f ,

    Jaques is right... if you enable the "initialize" checkbox for the 'speed' input, the movies should never start until you tell them. If that's not the case, file a bug report and we'll look into it immediately.
    Best Wishes,

  • Jaques and Mark,

    Thanks a million for the quick fix. 
    Problem solved ...and learnt something.
    best regards

  • Dear @tim_f,

    Glad it worked. But just to complete this thread: the reason the movie player played was because Isadora must tell the movie to start playing before it enters the scene. This is because it can take up to 100 mS for the movie to deliver the first frame after you tell it to play. Therefore, to have the first frame ready by the time the scene has actually become active, Isadora tells the movie to play at the end of it's "preload procedure", which is done when you Jump into the scene. The reason it worked some times and not others is unfortunately somewhat variable, which is an inherent problem in both AVFoundation and QuickTime. In other words, sometimes your zero speed go to the movie before that first frame could actually be delivered.
    Hopefully that allows you to make some sense, and is also to document the fact that this behavior is not a bug but just an inconsistency that we have to live with.
    Best Wishes,