TouchOSC crashes isadora?



  • Dear all,

    New to the forum, so I don't know if the category is the right one, sorry :-)

    I have an OSC-problem that I can't seem to solve...

    I am creating visuals for a concert, where I want a few audience members to be able to control the visuals. My hope is to do this via TouchOSC from maybe two or three ipads.

    I have attached the izzy-patch and a screenshot of my touchOSC layout (I couldn't attach the touchosc-file for some reason)

    As you will see in the patch, for the first scene I want one ipad with two buttons (/isadora/1 and /isadora/2) to be able to switch between two videos (Movie player 2 and 3) after 57 seconds. Then again after 139 seconds I am returning to my initial video (Movie player 1).

    Also, I have created a macro called "LED to Ipad", where I want to send a signal the other way -- from isadora back to the ipad. The idea here is that the audience should be able to see what video is active -- so if I on my ipad push button 1, movie player 2 will play and button 1 turns green. If I then press button 2, movieplayer 3 will play, button 1 will turn off and instead button 2 turns green.

    This all works perfect if I am just triggering from the computer - I can also send signal to the ipad with no problem.

    But as soon as I am triggering from the ipad, Isadora crashes.

    Does anyone have an idea on how to solve this?

    It seems like an OSC-problem, but it could also very well be something else -- maybe it is just that Isadora can't handle the three videos playing at the same time?

    I really can't figure out what is going on :-)

    Thank you all,

    Best,

    Magnus
    0be97d-skrmbillede-2012-10-17-kl.-11.58.33.png 7b3227-kiss_master.izz


  • Tech Staff

    What Isadora version are you using and are you on Mac or PC?

    Best
    Michel



  • I am on a mac (osx 10.6.8)

    Using Isadora 1.3.0f25
    With a 2 GHz Intel core i7 and 4GB ram
    Thanks!
    Magnus


  • i"d run some separate tests. i"d not use a macro. i"d run less videos. i"d attrmpt to work out where the source of the crash is. while running the tests, leave your intentions for the show aside, just work out what combination creates crash...



  • might also want to try it using Izzy f24.  f25 is still fairly new and probably still has some kinks to be worked out.  (btw mark is very responsive to bug reports so if you determine that it is an issue with f25 please file a report).

    eric


  • Dear Magnus,

    I use TouchOSC all the time -- I don't think that's the problem.
    Could it be that you added addresses /isadora/1 and /isadora/2 into the Stream Setup Window? This will cause a crash. If you're TouchOSC setup is sending on /Isadora/1, etc., then delete all items from the Stream Setup Window and try again. I think it will work.
    Best Wishes,
    Mark
    (Note: another user did what is described above -- f26 will prevent you from adding /isadora/1 into the stream setup window.)


  • Ahh, yes, I did add it into the stream setup. That was probably the problem... Now I tried it without and it is not causing any problems now!
    Wonderful! Thanks!


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.