Record Stage Settings / Syncing Problems



  • Hi there,

    I am working on an audiovisual performance in which OSC messages are being sent from one MacBookPro running SuperCollider to another MacBookPro running Isadora. Right now we are trying to turn this performance into a videoclip combining the recorded stage of Isadora with the recorded audio output of SuperCollider. But we have problems syncing the video output of Isadora with the audio output of SuperCollider. 
    Since I have way more experience with audio and SuperCollider ( samplerate is set correctly in SuperCollider and the recording DAW Reaper), I am quite sure that the problem is with the way Isadora is set up. The video file that comes out is about 3/4 of the length of the audio recording, while the video that is being projected live is perfectly sync.
    We have set the fps in both Isadora and Reaper (in which we are recording the audio of SuperCollider) to 25\. Since we have taken a close look at the samplerate and frame rate (which seemed in first instance the most logical problem), we are suspecting compression issues to be the cause. Could that be the case? And what would be the best record stage and compression settings?
    Furthermore we are using a video camera (need to check the brand with my partner) for live capture. I read on a post from Mark on this forum that it is best not to mess with the live capture settings. 
    Any light on this issue would be greatly appreciated!
    Take care,
    Sjoerd

  • Tech Staff

    I would suggest using a digital video recorder of some sort, that would allow you to record the audio and video simultaneously.
    If that's not a possibility, I think we will need to know more about your recording settings.
    Are you using the "output / start recording stage" method? If so what are your recording and codec settings?

    Or are you using the "Capture Stage to Disk" actor?


  • Thanks for the quick response! Yes, indeed we are using the 'output / start recording stage' method. Is it worth checking out the "Capture Stage to Disk" actor for this matter? I guess not when it has something to do with the codec settings.

    When it comes to the codec settings, we tried H.264 with a framerate of 25 fps and a key frame every 25 frames. We also tried (just as experiments) Photo-JPeg, MPEG4-Video and DV-PAL, all with 25 fps, but still it was totally out of sync. I tried the DV-PAL, since I thought it was the closest I could get to uncompressed. What kind of compression would be the best or is it better to use as little compression at all? On my own computer (but we are using that one in the current setup for SuperCollider) I have Uncompressed 10-bit 4:2:2 and Uncompressed 8-bit 4:2:2, might that be worth trying out and installing these on the other machine? 
    Using a digital video recorder is a good suggestion - but since I am doing the audio recording as a multitrack in reaper, we would just record the video and then hopefully it captures it in the right. But it still would be great to get our heads about this (probable) codec problem... 

  • Tech Staff

    Are you rendering at 100% speed?



  • Yes, I am rendering at 100% indeed...



  • Hey. I found out that on another computer running OSX 10.11.5 everything is perfectly sync when recording from stage also using H.264 codec and a framerate of 25 fps. The computer where it went wrong was running OSX 10.10.5. Both computers are running Isadora 2.2.2 with a version 1.x license.

    Are there are any known issues with OSX Yosemite? 

  • Tech Staff

    No issues that I am aware of... h.264 is a core codec for AV foundation, so perhaps something in AV foundation changed between OS versions.

    I am glad you have found a solution. And thank-you for posting your findings. It may be helpful to other users.


  • Hmmm I had the same problem again with the other computer. I guess it has something to do with the cpu?


  • Tech Staff

    Do you have set to stop if dropped frames?


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.