assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[SOLVED] Limit-Scale Value Bug or misunderstanding?



  • Hi,

    I want to change the 'out max' value of a Limit-Scale Value Actor within a scene (from 100 to 50 in the example file), but when returning to the scene, start with 100 again, so I set the initialize of 'out max' to 100\. As I trigger 50 everything works as expected. When I leave the scene and return I can see the 'out max' has returned to 100 but the output stops at 50\. This behavior remains (even if you close the file and reopen) until you manually change the 'out max' setting. Any explanation highly welcome.
    best
    r

    061183-limit_scale_test.izz


  • Tech Staff

    @Reinhard

    I can recreate this and it seems to be a bug. Can you file a formal bug report? To get around this you have to de-select the initialize value and ad another trigger value of 100 with a enter scene trigger connected to it.

    Best Michel
    a963a9-limit-scale.png



  • @Michel

    Bug report filed. Your workaround does not work - it has to be something else than 100 - 99,99 works.
    best r

  • Tech Staff

    @Reinhard

    It did work for me, but it only works with 100 if you untick the initialize value that already initializes 100.

    Best Michel



  • Dear @Reinhard,

    Thanks for your patience in awaiting my reply to this, but I wanted to let you know this bug is solved. It was really the result of a bad design decision on my part, to automatically set the 'Limit Min' and 'Limit Max' of the output port based on the 'out min' and 'out max' inputs. (This has been part of the Limit Scale Value actor since I first made it.) I've removed this "feature" and I think the updated version of the plugin will work as you expect.
    Best Wishes,
    Mark

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.