Consistent crash after n scenes: Error: bad_alloc (out of memory) exception caught in LApplication::



  • Error: bad_alloc (out of memory) exception caught in LApplication::Run
    File: LApplication.cp
    Line: 248

    I am working on a project with 50 scenes.
    I have sucessfully run this project on a Mac.
    Now I am trying to get it to work on my PC.

    Consistently, after the 24th scene (give or take a couple) Isadora crashes with the error message above.
    When I watch task manager on the windows machine it says Isadora is using about 500MB of memory, which is about 15% of the installed memory...

    I have submitted crash reports some of the times this has happened, but not all.

    Deadline is Friday, clock is ticking....



  • Dear @mark_m,

    We know about a memory leak in the Gaussian Blur actor which caused a similar situation for another user. So if you are using the Gaussian Blur actor in your show, then please update that plugin in Isadora using the attached .zip file. Instructions on how to install are here: http://troikatronix.com/support/kb/installing-an-isadora-plugin-manually/
    If you are not using the Gaussian Blur actor in your show, then I'll look at the Crash Reports. But the only way to find them is if you used your email address when submitting the report. Did you do that?
    Let me know and I'll follow up with you here. The email address associated with your account here is a .co.uk address. If you didn't use that email when submitting the report, then send me a private message telling me the email address you used.
    Best Wishes,
    Mark

    bddd8d-fixed-gaussian-blur-v2.2.2.zip



  • Thanks for your attention, @mark.
    No, not using Gaussian Blur.

    Yes, I did include my email addresses when I submitted the bug reports. One of the them reports (I think I submitted three as Isadora crashed) had dropbox links to the project and assets . I will PM you now with those links too and with my email address(es),

    Thanks a lot. Appreciate it.

    Mark

    Mark



  • Dear @mark_m,

    After a quick look at your .izz file, one question: I see several pictures that are PSD (Photoshop) files. Do those files have layers? If so, my immediate suggestion is that you output all of these as single layer TIFF files and replace the PSD files in Isadora.
    Also, I need to know:
    1) Codec and resolution of your movie files. I noticed you had several .mp4 files. Playback of these files under Windows may not be optimum. Better to use Apple Pro Res if you have an SSD drive.
    2) Resolution of the picture files. 
    Best Wishes,
    Mark


  • Hi @mark
    The PSD files do not have layers as such, but they have transparent 'holes' in them which is necessary for the project to work (I am placing a live camera feed behind these 'holes'). So the file format has to have a transparency ability. I have replaced all the PSD files with PNGs,  but I get the same issue. I have sent an updated crash report.
    The picture files are 1920 x 1080px @ 72dpi

    Since it's most awkward to produce ProRes files on the PC I have been using MP4. These files are only being played forwards, not manipulated in any way. I get playback speed at 24.4 fps and 170cps in Isadora. That's OK isn't it?

    Thanks

    Mark


  • Tech Staff

    MP4 is the container (similar to .MOV) do you know what the codec is, such as H.264 for example?



  • Hi @skulpture

    Greetings from Sheffield!

    It's H264


  • Tech Staff

    @mark_m

    Regarding mp4 on Windows. These video containers 'can' be fine. The issue is that they may contain nearly anything, and mp4 is played on PC by QuickTime (although Direct Show support is available from the OS, but very limited). 
    So if you are exporting the mp4 file/s on your Windows machine, you are likely using a codec/settings that are not optimal for QuickTime playback.  My experience has been that 4 times out of 5, mp4 files are related to user issues.
    Eg: I have been able to create 4 versions of a video, in a mp4 wrapper with h264 compression on my pc all using slight variations of the standard. Playback is not consistent between them, and can lead to a crash.
    Are you specifically trying to create the project to be cross platform? 
    If so I might suggest Hap. (HapQ for higher quality, and the latest Hap beta codec offers HapQ alpha)
    If not, wmv as a container provides the best DirectShow support, and Hap offers the best interactive playback.


  • @DusX

    Thanks, Ryan.
    I did try telling Isadora to play back the H264/MP4s via Direct Show and things didn't improve.

    Am now re-encoding the video as HAP and as WMV. Let's see what happens :-)


  • Tech Staff

    @mark_m

    I think this will help you a great deal.
    Direct Show playback of mp4 in Isadora is not supported. I think you may have miss understood me when I mentioned its OS support.


  • @DusX

    With an H264 .mp4 loaded in Isadora's movie player I can choose DS from the playback engine. Is that not using Direct Show?

    Anyhow, I have just tried replacing the H264 files with HAP files and the project is still crashing. So I don't think that's the problem here.

    (I notice on the automatically generated bug report that Isadora sees my computer as having 2GB of RAM rather than the 16GB installed. Is Isadora a 32bit program, and thus only able to address 2GB or 3.6GB of RAM?)
    8fb72f-ds-show-playback.png



  • Here's the resolution to this problem (thanks to @DusX 's eagle eyes and detective skills).
    The issue was that I was using the Textdraw actor, and the text that I was putting into it - copied and pasted from a provided script - contained non-ASCII characters. Something that the Mac didn't have a problem with, but that the Windows machines couldn't cope with.

    Once I'd replaced the offending characters everything worked as it ought: so the video formats and the picture resolutions were red herrings in this case, but none the less good to learn more about good practice.

    @mark, thanks for your help too: hope this makes sense.


  • Tech Staff

    @mark_m

    Just to clarify the 'pb engine' output setting. 
    This is not settable. This is an output provided, that shows the currently active playback engine. It can only be controlled ( to a degree ) by the 'optimize' input. Where 'Performance' will use AVfoundation or DirectShow if available for the media type, and 'Interactive' will use QuickTime for playback.
    The fact that you can physically alter an output has no effect on the actor since no setting is input.

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.