assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Sending TCP to Christie S+ 10k


  • Beta Gold

    Hello all,

    I am working on a production and they have expressed interest in controlling the two projectors we are using with TCP commands.
    I have the TCP commands I need to use, (please see attached image), but I have never worked with TCP before and am finding it a bit confusing.
    I know that there are four TCP actors in Isadora, and that I need to connect to the projectors via an ethernet cable, but that's where my knowledge ends on the subject.
    Can anyone give me a few pointers in the right direction? I would greatly appreciate it. 
    Thank you in advance,
    Woland

    02c261-screen-shot-2016-06-28-at-1.04.46-pm.png


  • Beta Gold

    @bonemap I seem to remember you being a TCP aficionado


  • Tech Staff

    @woland I recommend first working thru this tutorial. It will at the very least get you familiar with all the elements. http://www.dusxproductions.com/blog/web-apis-in-isadora-part-1/


  • Beta Gold

    @DusX

    Many thanks! I will take a look at it during dinner.

  • Beta Gold

    It has come to my attention that the script I was given is Applescript that was actually intended to be run through QLab.

    According to Christie's documentation, all I need to do is send "shu1" or "shu0" to the projector, on port 3002 in order to shutter and unshutter it. 
    I have attempted this but have thus far been unsuccessful; no response from the projector.
    I'm going to keep at it, but any advice would be welcome.
    Thanks again,
    Woland

  • Tech Staff

    @Woland

    Do you have the IP address of the projector? You will need it.
    I have looked thru an actor available here: http://troikatronix.com/troikatronixforum/discussion/1204/projector-shutter-control
    for a sanyo projector, and it looks like in the case of that projector each call required a return be sent followed by a command.
    No special formatting like a TCP-IP get request, so easier than a web request it seems. So.... I then looked at a christie pdf manual.. and see that the commands appear to be shown as "SHU 0" and  "SHU 1"
    You might want to try commands like: "SHU0\r" or "\rSHU0\r" or "SHU 0\r" or "\rSHU 0\r"  (these may also be entered like the examples in the tutorial, where the strings are enclosed in quotes, and the invisible characters are outside the quotes in hex. Example  0D"SHU 1"0D  )
    These would be the strings entered into the 'TCP Send Data' actor. (the rest would work similarly to the tutorial I pointed you at)
    Those strings are just a guess. I added the returns "\r" since the sanyo actor used them.. but its possible they are not needed at all.
    I hope that helps.


  • I think you can use the hex PJ link commands which are close 25 31 41 56 4D 54 20 33 31 0D and open  25 31 41 56 4D 54 20 33 30 0D


  • Beta Gold

    @Dusx @Isadora

    Thanks! I have been trying all of these different iterations of the commands but am still not getting a response from the projector. 
    Is there a way I can ping it to see if I am actually connected or not?
    I know the IP address, do I have to make sure that I set a manual IP address for my computer as well or something?

  • Tech Staff

    @Woland

    One thing could be if you have set the IP manually for your network connection to the projector and use WLAN for the Internet there could be a problem because of the different IP ranges they are using. Try dissabling WLAN (if used for internet connection) and see if this helps.

    Best Michel



  • You will want to make sure that the projector and your computer are in the same nework range like 192.168.0.xxx. You can always check your connection by putting the ip address of the projector in your web browser. If it works you'll get a Christy login window. You may need to disable your WiFi or change your network service order so ethernet is top of the list.


  • Beta Gold

    @Michel @Isadora

    Thanks again for the suggestions. I will try these today after rehearsal.
    Cheers,
    Woland

  • Beta Gold

    Update. Still not working, but:
    • Set static IP manually on both the projector and the computer

    • Also made sure they were on the same subnet (192.168.0.xxx)

    • Turned wifi off

    • Ethernet 1 says "connected"

    • Saw that I am connected to the projector by typing the IP into the Firefox Address bar (I got the Christie login window)

    • Also confirmed by successfully pinging it via the terminal

    • Have made sure that I am connected to the projector via a network switch/router which I have verified as being functional, as per a suggestion I received elsewhere

    • Tried a number of formats for the TCP Commands (see attached photo)

    • I have seen a number of posts about other projectors saying you need to disable the password, but as far as I can tell, (after having gone through all of the menus), there is no way to set a password on this particular projector

    • I have contacted Christie Tech support. They said that the M Series of Christie projectors are not PJLink compliant. (Full email is attached as image).

    • They suggested connecting to the projectors via RS-232, but I'm trying to avoid physically touching the projectors at all costs because I really want to avoid having to do a whole show's worth of remapping for two projectors.

    Questions:
    • Do I need to input something in the box for "Router" info in the Network preferences?
    • Have been using the User Actor posted here by @cambrucedavis. It was created for PJLink, but looks like it should be able to do what I want in theory. (I think it does but, again I am brand-new to TCP.) Am I correct in thinking I can use this for my own purposes?
    • Any thoughts on what I am missing?
    Future Plans:
    • Currently I am branching out to investigate virtual machines to run Christie Powetool (their PC-only control software). (Another thing with which I am completely unfamiliar.)
    • I have bootcamp on my laptop and feel that I can probably run Christie Powertool on my laptop and network it to my Mac Pro to trigger it through Isadora.
    • I could also just network a windows laptop we have here with my Mac Pro and try that. (Though I am unsure of how to do this, and even if I did know, I am unsure of how to control Christie Powertool on another computer using Isadora.)
    • Bang my head against a wall repeatedly.
    • Commit seppuku with the projector remote.
    Once I figure this out, I think it might not be a bad idea to create a Knowledge Base article on controlling projectors via TCP since it is SO crazy difficult to find information about this, not just with Isadora, but in general. 
    (Seriously, googling "+projector +TCP" nets you a grand total of five hits. Five!)
    I will beat this thing, I swear it!
    Thanks everyone for the advice and help,
    Woland

    6ec2dd-screen-shot-2016-07-01-at-10.40.13-pm.png e4a92b-screen-shot-2016-07-01-at-10.47.00-pm.png



  • Have you tried "(SHU1)" and "(SHU0)"


  • Tech Staff

    Looks like you have attacked this pretty well. I can't think of anything off hand to improve the setup. I will try to do the same with my Panasonic. . It won't be the same but perhaps I will find a related hurdle.


  • Beta Gold

    We finally got it working, but through QLab. I'm itching to try to do it through Isadora, but we simply do not have the time at the moment. To the best of my (limited) knowledge of networking, the issue was something to do with our ethernet switch, which did not have a DHCP server (or something). Our sound technician, who is very knowledgable about networking, plugged it into a spare router he had and got it up in running in about half an hour. I plan to post more details after the show is over and I have more time.


  • Tech Staff

    @WolandI

    I am glad you found a solution in time for the show.
    It would be great if you could migrate the solution to Isadora and share it. As you pointed out there is very little information on these things available
    If the problem was hardware related, thats a tough one to pin down.

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.