USB Video Capture



  • Hi there,

    I'm trying to do a simple video capture that used to work with my old set up, and the only thing that has changed is the Izzy upgrade, so wondering if anybody can help me out. It's probably very easy. I'm running my sill Canon HD Vixia HFM50 through and admittedly quite old Roxio Video Capture USB dongle into Izzy and out to projector. I'm using the Video Glide software and video glide is reading the camera fine. Isadora isn't picking it up though...weirdly enough it does see it as an audio input, just not a video input. Did something change in the Izzy upgrade that causes me to need something more...or am I just forgetting how I used to do this? 
    Any thoughts greatly appreciated.
    j


  • Does the device show up in the Device? Red Box?

    And also do you have a button to force JPEG capture? Blue Box?

    4945be-screen-shot-2016-07-21-at-09.56.25.png



  • Thanks for your response, Graham.

    Neither of the video capture devices I've been trying show up in the Device. I do have the forced jpeg button, but clicking or unclicking that does me no good. 


  • Does anybody have any thoughts on this? I can't for the life of me figure out why Video Glide will read the camera, but Izzy won't. It's become pretty time sensitive, too!

    OR, how do I get Izzy to read the camera through hdmi, which is its other output. Is there a different device/software that will facilitate that?
    I hope someone can lend a hand.
    Thanks,
    Jake


  • I can't think of a reason why it wont work. The best way to capture HDMI is via a capture device. A lot of people are using these: 
    Blackmagic Design UltraStudio Mini Recorder

    https://www.amazon.co.uk/Blackmagic-Design-UltraStudio-Thunderbolt-BMD-BDLKULSDZMINREC/dp/B009D91314


  • Well...this is pretty irritating. I know it's not your fault, Skulpture, but the forums are the only place to go for help. And I've used this exact set up before and Izzy should be able to handle this NO problem. I've now tried 4 different usb capture devices and all work with Video Glide but none are being read by Izzy. I've played around a bunch in video glide's setting but I'm getting nowhere. I can get Epocam to read in Izzy, but not Video Glide. I'm at a loss and since I need two of them I don't want to drop a whole bunch of money on these Blackmagic devices, only to find that it doesn't work either.

    Has anyone else experienced this and found a solution?


  • Just out of curiosity, if you install Isadora 2.1 does the same thing occur?

    You can download izzy 2.1 in the drop down menu here:
    http://troikatronix.com/download/isadora-download/
    Sorry that you are experiencing problems with this. We will get to the bottom of it. 


  • Thanks, again.

    So I installed 2.1 and...Izzy seems to read composite...it shows up in the devices, but it gives me a pink preview box. Again, Video Glide reads the camera fine. 
    I'm at a loss because there's not much tinkering I can do with this function and, again, it used to work completely fine. I've done this exact very simple thing many times.
    Any other thoughts?


  • I'm probably too late responding to this, but I used Videoglide with Isadora 2.2.2 and a Hollywood Dazzle today just fine (2012 MBP, Yosemite).  You mention that you saw a pink screen; Videoglide uses coloured screens to indicate various errors.  Pink (red) indicates that the device is being used by another program.  Perhaps you still had the Videoglide software running when you were trying to access the camera through Isadora?

    Craig


  • Dear @jrhooker,

    I think @CraigAlfredson might be right. In fact, my first suggestion is to **_not_** run Video Glide at the same time. It's probably got control of the camera, and Isadora can't get at it if this is the case.
    To try to test this out, I downloaded Video Glide and connected an old XLR8 capture device. Unfortunately, I don't have anything that produces composite video here at the house, but I was able to enable capture, seeing a green screen with the EchoFX logo. I can try this with a camera on Monday, but the pink screen on your end would indicate something else is awry.
    From the VideoGlide Manual: "The most common color you will see is green: no video source is plugged in and playing. If you see any other color, refer to the trouble-shooting section for details." 
    Then in the trouble-shooting section:
    • Red: no digitizer - make sure a digitizer is plugged in and that it is not being used by another application.
    • Yellow: low-power - digitizer needs a USB powered port in order to operate.
    • Orange: need USB 2.0 port - digitizer needs a USB 2.0 port in order to operate.
    • Green: no video - plug a video source into the digitizer and make sure it is playing.
    • Purple: USB error - This will occur if the digitizer is unable to allocate the USB bandwidth that it wants. See the trouble-shooting section "I get a purple screen instead of video" for more information.
    Best Wishes,
    Mark


  • Well, I think it's official: I have no idea what I'm doing. I'm obviously doing something wrong. I don't understand how to "use VideoGlide with Isadora 2.2.2" as @craigalfredson did and yet not have VideoGlide running at the same time as Isadora. I mean: when I don't have VideoGlide running Isadora doesn't see my camera and when I do have VideoGlide running Isadora doesn't see my camera. I appreciate your help so much, but, Craig, can you lay out exactly what you did?



  • @jrhooker

    Exactly what camera are you using?
    What about trying QuickTime Player 7\. If you set the it's Preferences to see Video Glide as the source, does it recognize the camera successfully if you choose "New Movie Recording" from the File menu? (For sure it will not work in QuickTime Player X. It won't see the Video Glide driver.)
    Also, I don't think the fact that VideoGlide itself shows the camera to be proof that something is wrong with Isadora. Remember, VideoGlide is a stand alone application that – very likely – bypasses the QuickTime driver required by Isadora to get video. The test with QuickTime Player 7 is a much more valid test. If it shows up in QuickTime Player, but not in Isadora, then I would be ready to blame Isadora. But if QuickTime Player 7 doesn't see it, it shows there's something up with VideoGlide's driver.
    Best Wishes,
    Mark


  • @jrhooker,

    I edited the above comment several times, so I'm adding the @jrhooker here to ensure you read what I had to say as it stands now.
    Best,
    Mark


  • Thanks, Mark. I'm away from my computer right now but I'll definitely run your test when I get home. For the record, I'm using a canon vixia hf mf camcorder. And just to be clear, I'm not blaming Isadora...I'm fully ready to accept this is user error on my part. The weird thing is that I've done this all before with the same gear and it's worked fine. But as you know, I'm no programmer or gearhead and so I often screw up simple things.



  • Dear @jrhooker,

    Well, it's important to know if Isadora is to blame so we can fix it – I'm happy to accept the blame if it makes the program better. ;-) But run the test and let me know.


  • Hey, @mark ... sorry about the radio silence on my end. I bought a Blackmagic shuttle Intensity that I was trying to get to work, but I'm failing on that too. So, I came back to this.  I can't run your Quicktime 7 test though.  You need the Pro license in order to record new movies...and I can't for the life of me figure out how to buy one.

    I don't know...this is pretty frustrating. I've been trying to troubleshoot getting unglitchy livefeed for a long time now and now I'm 4 days away from a work-in-progress at NACL. When I conceived of the show, I just thought getting livefeed into Izzy would be a breeze. I was wrong. Any help would still be greatly appreciated. I'm not sure if I should be troubleshooting the blackmagic (their tech support was no help) or troubleshooting the video glide method.
    Here's what I'm doing, just so you know. I'm taking live feed in through composite with a long run...like 50 feet...because I'm live feeding essentially the whole show and I move around a lot. My camera is a Canon Vixia HF m50\. The two methods I've tried are 1) camera>composite>usb video capture>syphoner + video glide (this works but is really laggy and sometimes freezes) and 2) camera>composite>blackmagic shuttle intensity>izzy (i can get izzy to see the camera, but it's just black...it's also black for the blackmagic proprietary software, even though it recognizes the hardware). 
    So @mark...@skulpture...@ anyone!!! Any help?
    Thanks!
    Jake


  • @mark and @skulpture...crisis averted. I got it to work. And this whole stupid saga has to do with me just basically doing things wrong. It's too embarrassing to go into, but it works and now I've wasted many hours of my own time and yours and I'm behind! Geesh. Thanks for your help and sorry if my tone was ever biting. I was just frustrated.



  • Glad you got it working.

    It would be interesting to know what it was (maybe PM me?) only because the problem could occur again and I could help a future user.
    Thanks.

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.