assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Disabled gl shaders still eat frames



  • Fun fact. A scene with 20+ gl shaders, connected to nothing, pushes my fps down to 5fps. I guess the code is still being looped through even though there is nothing connected to the output. F



  • Dear Fubbi,

    Well, just because they aren't connected to an output doesn't mean they are "disabled." These actors don't sense whether or not there is something connected to the output
    If you do the following though, you should be able to control it:
    1) Connect multiple GLSL Shader actors to a Selector actor with the appropriate number of inputs
    2) Double click the eye icon on the Selector actor
    3) Enable the 'exec src' input
    4) Set 'exec src' to 'gated'
    Now, I'm 90% sure only the GLSL Shader actor that is routed to the output will execute. I say 90% only because it's nearly 1am here and don't have the wherewithal to test at this moment.
    Why? Because whenever an Isadora actor is at the end of a chain of actors, it will be executed, as will all upstream actors. In your case, the GLSL Shader actors are the end of a chain, and thus they are executed. When you use the Selector actor with in 'gated' mode, only the chain of actors that is actually routed to the output will execute.
    Try it.
    Best Wishes,
    Mark


  • yes this works very fine indeed!!
    Thanks @mark


  • Tech Staff

    @mark

    A bypass input would be a nice addition, and would make a clear option for less advanced users.

  • Tech Staff

    also, theĀ 'exec src' = 'gated' trick is one that should have a knowledge base article I think.



  • Holy cow. This saved me! I just installed a patch with 40 shaders here in beijing and had to squeeze them into one scene. Boy am I glad we talked about it.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.