[SOLVED] Windows screen + resolution recognition

  • I have to agree with Mehdi, when you scale the screen resolution to 100% in order for Isadora to a) see the correct resolution of attached screens and b) output stages to screens it become so very hard to read the patches. It would be great to have this fixed.

    See next post for screenshots

  • The first is with Windows set to the "recommended" scaling of 250%. Easy to read and work with.
    The second is with Windows set to 100%: the scaling necessary for Isadora to a) see the correct resolution of attached screens and b) output stages to screens. Hard on my eyes!

    c620a5-isadora_win_uhd-screen_250ppercent.png 678541-isadora_win_uhd-screen.png

  • Dear @mark_m, @keftaparty, and Everyone,

    Yes, this is a bug. You should not have to set the scaling to 100%, so you don't need to post further on this. I've arrived in Berlin this morning and am about to go fetch my Windows machine and start working on it. I'll update you here when I have news.
    Best Wishes,

  • Thanks @mark, hugely appreciate your efforts, and how much you care about we who use Isadora.

  • @keftaparty & @mark_m

    One question about this: I assume you are using laptops with high resolution screens, e.g., like the retina display on the Mac Book Pros. Yes? I guess you wouldn't need to enable the 150% text scaling if that wasn't true, but please verify. If you _are_ using laptops, then how are you attaching two displays to them? Is that just a feature of the laptop you have? (Sadly, I the laptop on which I will test does not have that capability.)
    Best Wishes,

  • Hi Mark,

    I think any NVidia GPU from 7xxm series support 3 screens.
    Most of the time, the laptop's screen + 2 external screens.
    I don't know AMD mobile GPUs
    I have been wondering if this could be an optimus related thing, but :
    I am having this issue not only on my laptop.
    I have a workstation with a 4k screen + a 2560x1440 screen, GPU is gtx1080, I'm getting the same issue.
    So no optimus...

  • Hi Mark @mark On the laptop in my signature it is a high-res screen, retina-like but with 4K (UHD) resolution of 3840 X 2160. I am outputting screen/stage 1 via the laptop's HDMI port to a 1440 X 1050 projector, and screen/stage 2 via HDMI connected to a second 1400 X 1050 projector via the laptop's thunderbolt port and a thunderbolt to HDMI adaptor. If I can help further, or you'd like to remote connect to share my screen, just drop me a PM. Thanks Mark

  • on my home machine.. I have a Nvidia GTX970 both display (monitors) show properly at 1920x1200

    on the machine at church, it has a Nvidia GTX750ti

    one monitor at 1920x1080p  one 1280x720p projector one 1920x1200p projector.. the 1920x1200p

    windows 10.. latest nvidia driver.. no scaling..

  • Dear @keftaparty, @mark_m,

    Thank you for these details. One further question: are you scaling on the main monitor (the 4K/UHD) screen and not on the other displays? Or some combination of scaling on and scaling off the various displays?
    Best Wishes,

  • @mark, scaling only on the main monitor. It's at 100% on the other displays. HTH, Mark

  • @mark_m - yes that helps. I think that's the source of the issue.

  • Hi @mark ,

    The problem occurs when the scaling is on any monitor ( not only the main one).
    But ! If applying the same scaling on both monitors, the problem gets "solved".
    I actually have :
    1 x main monitor 4k that "needs" 150% scaling
    1 x second monitor QHD that "needs" 100% scaling
    the second monitor is the "stage"
    If I scale the second monitor to 150%, witch makes it not comfortable for desktop use, but anyway the goal is to use it as a stage, then isadora is fine, seeing it at the good resolution.
    that's my 2 cents tryout of this afternoon...

  • Dear All,

    @keftaparty and @mark_m report that the new beta (2.4.5b04) solves this resolution issue. Please download the update from 
    Best Wishes,

  • Its' fixed for me.. i have full HD 1920x1200 going!!! thanks Mark..