Kinect V1 and Processing



  • Well, after the totally awesome Werkstatt this summer, I finally get the chance to put some of what I learned to use, playing with the Kinect.  Unfortunately, I've hit a wall.  Are the tutorial pages now out of date?  After attempting to install on a windows machine (many, many problems there, including missing Spout files, and not being able to find SimpleOpenNI to import), I tried again on my 2014 Macbook, running Yosemite  I'm on Isadora 2.4.5b13, but that doesn't really matter, as I haven't made it past Processing.  I followed the tutorial to the letter, but I'm getting errors (see below).  I should note that I'm using the 1414 model, and while everything worked well in Berlin, I did buy a new power adapter for use here in the states, so maybe that's faulty?  When connected, the Kinect's green LED flashes.  Any thoughts?

    Doug
    Here's the log:
    Setup Canvas
    -- Canvas Setup Complete
    Setup Syphon
    Syphon 1.0-RC3 by Andres Colubri http://interfaze.info/
    Setup OpenNI
    SimpleOpenNI Version 1.96
    After initialization:
    SimpleOpenNI Error: Can't open device: DeviceOpen using default: no devices found
    Can't init SimpleOpenNI, maybe the camera is not connected!
    kCameraImageMode 4
    enable User
    Setup OSC
    OscP5 0.9.9 infos, comments, questions at http://www.sojamo.de/oscP5
    ### [2016/10/15 21:34:13] PROCESS @ OscP5 stopped.
    ### [2016/10/15 21:34:13] PROCESS @ UdpClient.openSocket udp socket initialized.
    ### [2016/10/15 21:34:14] PROCESS @ UdpServer.start() new Unicast DatagramSocket created @ port 9000
    ### [2016/10/15 21:34:14] PROCESS @ UdpServer.run() UdpServer is running @ 9000
    ### [2016/10/15 21:34:14] INFO @ OscP5 is running. you (192.168.200.23) are listening @ port 9000
    Setup Exit Handerl
    Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
    at processing.core.PGraphics.image(PGraphics.java:3572)
    at Isadora_Kinect_Tracking_Mac.OpenNI_DrawCameraImage(Isadora_Kinect_Tracking_Mac.java:130)
    at Isadora_Kinect_Tracking_Mac.draw(Isadora_Kinect_Tracking_Mac.java:276)
    at processing.core.PApplet.handleDraw(PApplet.java:2386)
    at processing.opengl.PJOGL$PGLListener.display(PJOGL.java:862)
    at jogamp.opengl.GLDrawableHelper.displayImpl(GLDrawableHelper.java:665)
    at jogamp.opengl.GLDrawableHelper.display(GLDrawableHelper.java:649)
    at javax.media.opengl.awt.GLCanvas$10.run(GLCanvas.java:1289)
    at jogamp.opengl.GLDrawableHelper.invokeGLImpl(GLDrawableHelper.java:1119)
    org.eclipse.jdi.TimeoutException: Timeout occurred while waiting for packet 105.
    at org.eclipse.jdi.internal.connect.PacketReceiveManager.getReply(PacketReceiveManager.java:186)
    at org.eclipse.jdi.internal.connect.PacketReceiveManager.getReply(PacketReceiveManager.java:197)
    at org.eclipse.jdi.internal.MirrorImpl.requestVM(MirrorImpl.java:191)
    at org.eclipse.jdi.internal.MirrorImpl.requestVM(MirrorImpl.java:226)
    at org.eclipse.jdi.internal.ObjectReferenceImpl.invokeMethod(ObjectReferenceImpl.java:428)
    at processing.mode.java.runner.Runner.findException(Runner.java:942)
    at processing.mode.java.runner.Runner.reportException(Runner.java:871)
    at processing.mode.java.runner.Runner.exceptionEvent(Runner.java:797)
    at processing.mode.java.runner.Runner$2.run(Runner.java:688)

  • Tech Staff

    @Fred ? Any ideas?



  • Not sure, but it is not finding the kinect, hardware I guess. Maybe you can find some other software to test

    "SimpleOpenNI Error: Can't open device: DeviceOpen using default: no devices found"

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.