assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Well geeezzzz HELP! I've lost OSC



  • Hi All

    sadly im up late on a job 
    and in the midst of it all I've lost contact with the OSC coming from processing
    OSCulator says it's flowing and the data is coming across
    BUT IZZY HEARS NOTHING...
    things were working fine but izzy crashed while listening to OSC there seems to be something that gets foreverstuck
    I've tried trashing every preference with noluck getting izzy to start listening again...
    re assigning ports - changing tags - everything I can think of
    reinstalling, etc
    anybody have a magic dance to get OSC running again?
    is there some hidden preference?
    HELP!
    and I will send an official bug report after the job... but at the moment have to keep going...
    Garret
    mac, 10.11, izzy beta 2.5b20
    ps - used "cleanup.app" to trash every referenced file and reinstalled and that worked untill the next crash...... 
    I do hope that some one can point out which file contains the OSC information.... (.....help ;-((.....)
    PPS
    ok I've been digging - looks like the settings for OSC assignments are in the .izz file and I noticed that I'm using a listener actor with a channel i once used before --- it _feels_ like the OSC listener is perhaps overlapping with the normal listener actors' channel assignments.. 
    or that when releasing the channel assignments in OSC they are not being scrubbed from the program file...
    im gonna have to see if I can fix and work around all the old OSC assignments even if they are long gone from the Communication Setup window..
    really not sure here... but trying.... thx all

  • Tech Staff

    Not sure what could be wrong. The only thing that comes to mind to try is adding something g to your processing to "throttle" the out going messages.. kinda like a MultiBlocker. 2x your target frame rate should be good. Otherwise... take a really close look at your messages. Izzy supports the standard and may not like non standard formats.


  • Tech Staff

    I think we need to see some screenshots if possible?

    it could be something as simple as a / in the wrong place, or a / missing. 


  • May not be the reason at all but it sounds a bit like a problem I meet when using Max4Live and edit the device using OSC in Max. When you go back to Live, the Port isn't released and I have to quit Max to get it working again.The situation is obviously different but the port release may not happen


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.