How to stop continous crashing on start due to crash report itself ?



  • Hi,
    isadora has crashed during making some testing. Since that it creates infinite series of crashing when starting.
    Worse, when installing and reinstalling isadora, the new copy of the software crashes also, and it is a fresh new installation !!! To me it seems that the crash report it self makes the application crash, and that when uninstalling the application some configuration files are kept so the new copy has already this information of precedent crash, that makes it crash, and so on.... Does anyone know where to find these files to delete and stop the infinite crashing loop ?
    I've tried the MS DOS command to erase the configuration files but it doesn t work? As a proof, after crashing my email adress is already written inside the crash report.... It must have been kept somewhere....
    I have this problem with all versions of isadora (1f3 and the different 2.0 version i have tried) and all the windows version XP, 7, and 10. (the same problem on 3 different computers)...
    Thanks !!



  • Normally, the best thing to do is to trash preferences. I dont know where it is on window but most of time it cures the problem.

    jacques

  • Tech Staff

    See the link where to find the prefs on Windows. http://troikatronix.com/support/kb/delete-isadora-preferences/
    Best Michel

  • Tech Staff

    Preferences are stored at: C:\Users\YourUserName\AppData\Roaming\TroikaTronix

    There will be an .izp file that matches your Isadora version, you can safely delete these files.


  • Thanks a lot for your answers, I will check this out.



  • same thing is happening to me on windows 10. removing the preferences does not solve the problem.


  • Tech Staff

    Can you open Isadora, stop the engine, and then open your file?



  • hi, I tried all the ways of removing preferencies but it didn't work. Apparently some informations are kept somewhere else than C:\Users\YourUserName\AppData\Roaming\TroikaTronix
    about the crash reports that keep it crashing on and on... Do you know where it could be ? I am on windows 10 too.



  • @DusX @Michel
    Hi i have looked inside the computer and found those  locations with isadora files.
    C:\ProgramData\TroikaTronix
    C:\Users\tuby\AppData\Local\CrashRpt\UnsentCrashReports
    C:\Users\tuby\AppData\Roaming\TroikaTronix

    I erased everything, reinstalled isadora and still the crash continues.... This is just desperating.... Any idea what to do ? Should I modify something inside the register base ?


  • Tech Staff

    Crash reports really should not be the cause. So those folders probably don't matter. Do you have any freeframes , glsl shaders , and or UserActors being loaded into isadora? You may want to rename the folders that hold these files and the restart isadora. That will ensure that these files are not loaded. This is a common cause of startup errors.



  • @DusX; OK, I uninstalled the the freeframe and now it starts fine on windows 10. What a relesase !!! Thanks you !

    Does that mean that the TroikaTronix FreeFrame Plugin Collection for Windows is not compatible with windows 10. ?



  • @chrisdel what was your procedure for removing freeframe plugins? Did you need to reinstall Isadora again as well?



  • @rayroyiii  I used the command uninstall from the windows program lists. I didn't have to reinstall isadora.



  • Did not work for me. Isadora still crashes immediately. All preferences removed, free frame uninstalled. :(



  • :( I am using an old version of isadora : 1f3 on USB key. Maybe that makes a difference ?


  • Tech Staff

    @chrisdel

    even though you only have a version 1.x license I would recommend downloading version 2.x, there are a lot of fixes in there also for license 1.x owners. The only thing is that you will not benefit of the newest features.
    Best Michel

  • Tech Staff

    @chrisdel

    If you are running a older version of Isadora, it does not support the new freeframeGL format, only the older freeframe format. 
    The downloads available are Petes freeframes (older version) and the Newer Isadora FreefraeGL collection.
    Without seeing the error report I can only guess. But I would suggest trying the most recent beta, since it may have a fix that addresses your issue:
    http://troikatronix.com/isa25beta/


  • @chrisdel yes i've been trying the beta, it didn't work on my windows 10 machine, and recently freezes and is inoperable on my windows 8.1 intel i7 16GB ram nVidea GTX 960m workhorse. I uninstalled isadora 2.5 beta, removed preferences as per instructions on this forum, restarted machine, installed isadora 1.3, restarted, opened isadora.... crashes immediately.

    I will now try to install the older freeframe format and see if that helps, is there a procedure for removing the freeframe GL collection?
    i am considering completely wiping this computer, reformatting and starting over, but honestly i shouldn't have to do that, on two completely different machines?
    How can I send you an error report?
    thanks for the help,
    rr


  • crash report attached @chrisdel

    -rr

    7a12cf-isadora-crashreport.zip



  • OK, the freeframe uninstall and reinstall of the non GL collection worked on my i7 windows 8.1 machine.

    did the same thing on my i5 windows 10 backup, still crashed immediately. see crash report attached.
    rr

    d08d2a-isadoracrashwindows10.zip


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.