Help Glsl Shader and Windows 10



  • Hello

    After searching, tried and tried, here I am desperate, I can not operate the Glsl Shader.

    I do not have the image on the Stage. I read repeatedly GLSL Shader actor tutorial.

     

     Maybe I did not quite installed isadora?

    Or I'm missing a piece of information?

    I'm by testing on this computer ( Isadora 2.4.5, Windows 10 , Intel(R) Core(TM) i7-4790 cpu 3.60GHz, RAM16.0Go , Systeme 64bits-SSD 223.57 Go SATA III +              NVIDIA GeForce GTX 750 Ti )

    Add to this message a screen capture.

    Someone can give me some advice?

     

    Best regard 

    aa76f2-test-glsl.jpg



  • Hello,

    Its difficult to judge without looking at all the script…
    From where is coming your code?
    Have you tried with most basic shader, like in the Mark's tutorial?
    For complicated shader, you need a real powerful dedicated graphic card, perhaps it's the problem?
    You have also great sample in the "book of shaders"
    https://thebookofshaders.com
    Just be careful to suppress "u_" from some variables, it'd not recognized in the Isadora version of GLSL.
    Hoping you find your way to the joy of illumination.
    jacques


  • @Jacques

    Thank you for your answer.
    I have followed to in point the GLSL Shader actor tutorial.
    You can see that on the attached file, even a small shader is not visible on the Stage.
    sorry if my english is not so good.....
    My configuration (Isadora 2.4.5, Windows 10 , motherboard Gigabyte Z97HD3,   Intel(R) Core(TM) i7-4790 cpu 3.60GHz, RAM16.0Go , Systeme 64bits, SSD 223.57 Go SATA III intel(r) hd graphics 4600 integrate in mather board
    and graphic card : NVIDIA GeForce GTX 750 Ti  2go
    best regard

    29f091-capture.jpg


  • Tech Staff

    @Stefano

    just tried the last code you have posted and it works fine on Mac. I don't have a windows computer so maybe @DusX could try it.
    #ifdef GL_ES
    precision mediump float;
    #endif
    
    void main() {
    	gl_FragColor = vec4(1.0,0.0,1.0,1.0);
    }


  • @Stefano

    Same answer, it works fine on my Mac… Windows is a great black hole for me!

  • Tech Staff

    This code works fine for me.

    Outputs pink.
    is your system a laptop?


  • hola 
    Same answer, it works fine on my Mac out pink, but I want to also work in windows.
    So ; @Dusx, no laptop .
    video media and images perform well ....... 

  • Tech Staff

    @Stefano

    Maybe its would be best to issue a support request, and I could try to go thru and determine what about your system config is causing the issue.
    support link in my signature.


  •  @Dusx 

    hello sorry where is the link for support request? 
    I can not find it

  • Tech Staff

    [Bug Report/Feature Request FORM](http://troikatronix.com/support/isadora/ "opens a new window")


  • @michel 

    thank you , request sent .....
    I tried it on another pc and it works, in my compiuters still does not work
    So ..... best regard

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.