assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Fade in fade out times on scenes.



  • I think the fade in fade out times are not functioning as they should on scene transitions. If the fade out is set to 2 seconds and the fade in of the following scene is set to 0 seconds, there should be a hard cut as the incoming scene would by all logic have the 'top layer'. At the moment this is not so. 

    I thought I could get away with having an audio only fade of the scene while the video did a hard cut. As the system behaves now it does not really make sense.


  • Tech Staff

    @Fred

    You are right, by all logic depending on blend settings the video should jump. The jump actors do behave the same as the new scene fade settings at the bottom and I guess they were doing this since beginning. @Mark what do you think about the way it should work?

    Best Michel



  • @Fred

    Well, the way it works all has to do with how Isadora manages to cross fade from one scene to the next. In v2.0, each scene gets its own layer, and the 'layers' you know from the Projector actor are grouped within that. Now, when crossfading from one scene to the other, these "Scene Layers" (to give them a name) are blending additively. Which is where you're seeing the problem. I guess I never envisioned or tried the specific scenario you are trying.

    You can also get the behavior you're looking for by choosing File > Layering > Ungrouped. Then the Scene Layer approach is not used at all. Then the the layering is specified by the 'layer' input of the Projector only. (This setting is saved with the file, so you don't have to set it each time.)

    @Michel: do you agree with Fred on this? Should the newly activated layer be on top? To achieve Fred's desired behavior, one must render the layers of Scene 1 at full intensity, and then render the layers of Scene 2 on top, with a opacity that is based on the fade. I vaguely remembered causing problems with approach... though now I can't remember the issue. As a test, I changed to the code to do it Fred's way and – on a simple fade at least – it works. Hmmmm... this would change something that's been true since 2.0 came out. It's would require a lot of testing to be sure it doesn't break something.

    Best Wishes,
    Mark



  • @mark Cheers, that make sense - additive blending is the thing that makes it different. However I just tested your solution in 2.5.1 - it is not reliable, I have all my scenes set to 3 seconds out and 0 in (set in the previous scene) and I have some that respond correctly and some that do not. Also the behaviour if the next fade in box is not checked is strange, the first time I fade it does the fade out and then after the fade out the following scene starts, so the whole screen dips to black. I would have expected that not ticking this box is the same as having entered a 0 second time, now it ends up with a fade to black and then the second scene starting.

    Also your comment - "To achieve Fred's desired behavior, one must render the layers of Scene 1 at full intensity, and then render the layers of Scene 2 on top, with a opacity that is based on the fade. " is not correct for the scenario, it would be allowing scene to to render at whatever intensity is defined by the fade, and rendering scene two on top, but not with the additive blend mode.



  • @Fred

    RE: "... is not correct for the scenario" – I think it is, though I didn't explicitly say I would use transparent mode. I did this as a test in the code and it gave the results I believe you are expecting. To wit:

    You press the space bar in Scene 1. As soon as Scene 1 is ready start the fade, using this process:

    1) Render Scene 1 at full
    2) Render Scene 2 on top of that in 'transparent' mode, using the fade percentage as the opacity.
    3) Repeat until fade is complete

    The only reason this works is because the fade in on Scene 2 always starts immediately... there's no way to delay it. So, as Scene 2 fades in – whether that takes ten seconds or zero seconds – it obscures Scene 1 as the fade moves along.

    RE my suggestion: are all the layers the same, i.e., set to '0' or the same number? My suggestion won't work if that's not the case.

    Anyway, if my suggestion above doesn't work, then go back to the Grouped mode and try using layers on purpose. The projector(s) in Scene 1 need to have 'layer' settings less than Scene 2. This wouldn't work out if you were using this tecnique in every scene, because you'd eventually run out of layers. But if there's some normal dissolves along the way, you can start over with layer 0. See if that gives you a workaround.

    RE: the ticking of the box: if the box is not ticked, then the fade out time should be the same as the Fade In time. (Basically, when the box is checked you get the Jump++ behavior and when it is not checked you get the normal Jump actor behavior.) I'm pretty sure this works as expected. Was your comment with the Ungrouped mode turned on?

    Best Wishes,
    Mark



  • @mark Sorry, I should have been more clear RE: "... is not correct for the scenario"  - I meant that both scenes should be rendered at the intensity of the fade (not just scene 2), scene 1 starting at 100 and scene 2 starting at 0. Or maybe I am misunderstanding something deeper?

    Ill go through and cascade the layers in the projectors between scenes, I missed/forgot about this functionality, is there a limit to this? Does it use resources? I will have to go up 3 layers for every scene.



  • @Fred The layers are always being used, even if they are all set to 0. So there's no performance issue in using them.

    In terms of the fade thing: let's say you've set the fade out to 8 seconds and the fade in to 4 seconds. If we go with this different approach, Scene 1 (the 6 sec fade out) would be rendered at 100% for the entire duration of the fade. (Video, not audio!) But since Scene 2 is fading up, it would be rendered at 25% at 1 second, 50% at 2 seconds, 75 % at three seconds, and 100% at four seconds. Since it is being drawn in transparent mode, the background seems to "fade away" when it's really the case that the new top layer is fading in over the lower layer provided by Scene 2.

    Obviously if you had a 6 seconds fade out and 0 second fade in, Scene 2 would immediately make Scene 1 invisible, though the sound would take 6 seconds to fade out. That was your goal in the original post, yes?

    Best Wishes,
    Mark



  • @mark Obviously if you had a 6 seconds fade out and 0 second fade in, Scene 2 would immediately make Scene 1 invisible, though the sound would take 6 seconds to fade out. That was your goal in the original post, yes? 

    Yes this was the behaviour I was expecting. 


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.