SPOUT, upgrading to version 2.006


  • Tech Staff

    The latest Spout version is 2.006 

    If you are thinking about upgrading from 2.005 .. "The only real difference will be that they will not recognise "CPU" sharing mode. But that is only a backup for people with Optimus graphics incompatibility and should not be a practical problem." (Lynn Jarvis, lead developer)
    So for most users there will be no real benefit to the upgrade. Its really only worthwhile if you have Optimus, and have trouble with the current version.

    Another important difference between 2.005 and 2.006 for Isadora users is that the internal plugin ID's have changed. This means that if you make the upgrade to 2.006, project currently using the Spout FFGL plugins will not be able to locate the plugins (once they have been added to your freeframes folder) and you will be forced to delete the actors in your patch and add the new versions. Of course this can be a daunting task if you project is large.

    I brought this issue up with Lynn and he very kindly recompiled a set of FFGL plugins with the previous IDs to that we can have a drop in replacement that will not require rebuilding our show files :)
    Attached to this post is a ZIP that contains the NEW 2.006 FFGL files that work perfectly as a drop in replacement.
    To avoid future issues, a project branch will be made to ensure any future ID changes to the core ( some are coming ) will not break usage with applications that use the IDs internally.

    SpoutFreeframe2.006_16-04-17_recompiled-Izzy.zip

    note: the spout NDI plugins as well as some others probably also have ID changes. They are not contained in this zip file, and will require relinking.



  • @DusX said:


    I brought this issue up with Lynn and he very kindly recompiled a set of FFGL plugins with the previous IDs to that we can have a drop in replacement that will not require rebuilding our show files :).

     That's really kind of him! 


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.