assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Smooth horizontal movement of vertical lines?



  • Hi.
    I'm trying to produce a seemingly simple Isadora task: smooth horizontal movement of vertical lines. Since I have not been successful in accomplishing this, I attached a very simple patch using 'shapes'. If you look closely and patiently, you'll see what I mean. Whatever preference settings I use (target frame rate, general service tasks), I do not get smooth movement. This is not only the case with 'shapes' but also with 'lines'. Different output image sizes do not change the situation, neither does reducing system interrupts (internet). On top of that, both my Mac 2.4 GHz Intel Core 2 Duo laptop as well as my newer 2.6 unibody have the same issue. As it does not have anything to do with playing back movies, it cannot be a slow harddisk.
    Sure, in the attached patch I modified the input scaling of the 'shapes' actor to get a continuous re-appearing of the line. The alternative approach is to put a scaling actor inbetween the generating actor and 'shapes' and leave the input scaling of the latter untouched. Same problem, though.
    Any thoughts would be very welcome.
    Thanks, Jan-Bas
    8a7d30-lines-running-horizontal.izz



  • it looks fairly smooth to me, have you tried 3D Lines? have a look at this user actor that makes a nice effect out of vertical lines scrolling horizontally. e62e51-sine-lines.iua


  • Tech Staff

    @djbully
    If the target framerate is set to 60fps it is really smooth on my MacBook Pro 2.53 GHz Intel Core i5 with 4GB RAM, but its not smooth with 25fps or 30fps.
    Try to match the resolution of Isadora and your resolution settings to the projector.
    And what version of Isadora are you using?

    Does that help?

    Best,
    Michel


  • Tech Staff

    I too have played around with this, and although I get it to look very smooth at 60fps (30 is a little chunky due to step size) I still get random choppy glitches. Its rather inconsistent, so in the past I simply wrote it off as video card sync issues or something like that.. it was never a deal breaker for me, so I lived with it.
    I have now just been playing with my Nvidia settings and seem to have been able to improve playback by adding Isadora as a 3d application and adjusting vertical sync.
    Maybe similar will help you.



  • Thanks, guys, and dbini for sharing your user actor (that is the type of work I've been interested in lately). However, the 3d line actor is more cumbersome to work with than shapes. And indeed, Michel, 60fps is way better but not practical for me because I'm not using a projector but recording the stage to disk instead for post editing in After Effects and I get too many dropped frames. The latest Isadora version does not seem to make any difference compared to recent previous ones. Also, as DusX observed, it is very smooth but not perfect - occasional glitches. For recording, I use 25fps to be 'PAL consistent' throughout the process, and 640x480 (4:3) or 640x360 (16:9) resolution. Blowing this up in AE to a larger resolution later on doesn't create glitchy artefacts, strangely enough: It is the output from Isadora to start with that is causing the problems.
    A colleague told me I'm asking the impossible from a digital graphics system but I find that hard to believe.
    I will follow the Nvidia option as soon as possible and report.


  • Tech Staff

    if outputting from Isadora you should not have dropped frames.
    Have you decreased the output speed to 1/2 or less, and check quit on dropped frames.
    You should be able to decrease processing to such a point that you do not get dropped frames.



  • Dear Jan-Bas,

    Well, unfortunately, you are looking at the "worst case scenario" for Isadora... and probably many other softwares. The thing is, there is a clock that is determining when it's time to draw a frame. But there can be slight inconstancies in this... not very noticeable with a video clip, but extremely noticeable with a single line. (You can see the same problem when attempting to scroll white text on a black background.) There's all kinds of stuff here that makes this difficult to do well -- not the smallest problem being that there the amount of time it takes for OpenGL to render the frame from the time you say "go!" is not always consistent.
    For sure, you will want to set the render speed to a lower value using **Output > Record Stage Setup...** as DusX suggested. I think that should allow you to get the consistency you're looking for.
    If you have the Core Video Upgrade, you might try the attached version. Because it uses the Core Image subsystem, and there aren't texture maps to move into the GPU, it's more efficient and thus looks a more stable to my eye. Give it a try if you can and see if that improves the situation when just running normally.
    Best Wishes,
    Mark

    a4c663-ci-lines-running-horizontal.izz



  • Thanks Mark. I tried your patch, I can see the attraction for other uses but there are flickering artifacts at the edges of the vertical lines. So I tried again and again with my original design over the last 10 days and I have smooth motion at 50fps, animation codec and render speed at 25%, although I have to say I had to turn the "dropped frames abort" option off - don't see them, though. Maybe lowering the render speed even further will solve this. Now, rendering the footage into AE introduces stutter again, but I guess this is beyond the scope of this forum.
    I would like to thank you all for your comments up to now and will post a link of the result here once satisfactory.
    The thing is Mark, I am very happy with Izzy because it gets most of my jobs done approximately 4 times faster than with Jitter and 3 times faster than with Processing. And the job described above could be done entirely in AE, but of course without the real-time preview...
    Jan-Bas


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.