Isadora v2.5.2 is Available

  • @mark said:

    That said, now I need to clarify my language: when using the USB Key version, I would describe Isadora as being "unregistered" if the key is not present because it is not fully enabled to save. I guess I should have said "not fully enabled." 

     Thank you for the clarity. I will be able to try your advice about deleting preference files when I am back on campus.

  • Beta Platinum

    @mark said:

    the link you gave to the "About Isadora..." above did not work

     is this better - apologies in advance if it doesn't work

  • oops! I hope that's not too confusing - I have sent the link in the previous post using my personal forum profile instead of this Uni one.  

  • @Russell

    Thanks for this. But I need to see the splash screen for the copy of Isadora that won't show the projector. It will help me diagnose the problem.

    Best Wishes,

  • @mark said:

    the splash screen for the copy of Isadora that won't show the projector

    Here is a link to the file.

    The earlier image with the key active and this one without the key and in demo mode where calling the projector brings on the dialogue box warning.

  • @mark said:

    on the unregistered machines, please go to /Users/Shared and delete all files that have Isadora in the name. In addition, please go to ~/Library/Preferences and delete all Isadora preferences.

    I can confirm that after deleting the Isadora named file found in /User/Shared and 3 x Isadora named preference files from ~/Library/Preferences, and restarting the machine - the issue has persisted.

  • @Russell

    I tried to recreate this going through several configurations:

    1. Register with 1.0 license. Run with key inserted
    2. Run without key inserted
    3. Register with 2.0 license. Run with key inserted
    4. Run without key inserted

    In all cases I was able to insert the Projector actor without any trouble. I can't think of any other situations that might cause this. 

    Is this happening on all machines, or on a specific machine only? Does it happen on your personal machine when the key is not inserted?

    I think there's one other two other files you should try deleting which I don't believe I mentioned before

    In ~/Library/Preferences you'll find

    • com.troikatronix.isadora.scanned-plugins.txt
    • com.troikatronix.isadora.hidden-properties.txt

    Delete those two files as well before you try again.

    Best Wishes,

    P.S. You should make the free upgrade to the v2.5.2 release in any case.

  • @mark said:

    I think there's one other two other files you should try deleting

    My initial deleting ~/Library/Preferences included those files:


    and I deleted the file in /User/Shared as suggested - so the result is the same.

    The dialogue has appeared on multiple machines MacPro, Imac and MacBookPro - all of these machines have a University based system image. As it appears that no one else on the forum is having the issue and it doesn't appear to be present in the new release I am having the Uni machines updated to 2.5.2. I will ensure to let you know if the issue appears again.

  • @mark said:

    upgrade to the v2.5.2 release

    Not good news I am afraid - for your reference after downloading and running the 2.5.2 installer for the standard edition on a MacBook Pro and running demonstration mode the same dialogue box has appeared when attempting to place the Projector.  This did not happen initially but has developed after physically demonstrating patching using demo mode. Again the machine has a system image provided by University ITC staff, I am prepared to refer the issue to an ITC staff member if you want to pursue it.

  • @Russell,

    OK, this obviously is going to require some deeper effort on my part to recreate the issue. I myself won't be able to look at this again until Monday. If you are in urgent need to use Isadora, please go to our help page and open a ticket. One of our team will arrange to get you temporary licenses for the standard edition until we can get this solved. 

    @crystalhorizon @DusX @mc_monte: if you see a ticket come in from Russel, get it routed to Xenia so she can handle it ASAP.

    Best Wishes,

  • @mark

    Hello. The same problem at our win10 machine. No projector in demo mode of usb 2.5.2.

    Any suggestions?


  • ....and the funnyest,

    Also the video in watcher is gone.

    After delete all prefs with the .bat from works again.

    Then about a hour later ptojector and video in watcher are gone again.


    Thx. R