3D Model Particles Render Draw



  • Hi all, 

    Quick query, I seem to be experiencing some undesirable behaviour. 

    I'm using the 3d model actor, and have a simply 3DS file plugged in. 

    When I change the render mode from 'stage' to  'renderer' the screen is not cleared as the visual moves downwards. 

    I've attached a couple of print screens to help explain my problem. 

    Cheers 

    Ed


  • Tech Staff

    @grimvisions

    What Isadora version are you running.

    I have a memory of this coming up before and being addressed.



  • 2.51. 

    Thanks 

    Apologies if this has been address before! 

    Ed



  • @DusX 

    So I noticed the bug appears to disappear when a second 3d particle generator is added. So my fix has been to add this second particle generator and have no particles emitted from this 'null generator'. 

    Appears to have fixed the draw clear process. 

    I would be interested to know why you think this happens. 

    Cheers

    Ed



  • @grimvisions

    If you are willing to post the file that shows the problem here, please do. Otherwise open a new ticket with us (https://troikatronix.com/help) and send the file to us privately. Definitely want to make sure this is fixed.

    Best Wishes,
    Mark



  • I would Mark, however I seem to have fixed the issue and am unable to replicate it! 

    Would you still like the file? 

    All best wishes



  • @grimvisions

    Well, if you fixed it then I suppose it wasn't an Isadora bug. So no need to send the file.

    Glad you got it working.

    Best Wishes,
    Mark



  • @grimvisions

    could it be the settings you have in the 3D Particles? I see you have 5000 particles being emitted and gravity of -20 on the Y axis these parameters may give that effect depending on the frequency of particle births input at 'add obj' ? 


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.