assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

I cant access all the axis (Kinect through Ni-Mate)



  • Hello,

    I am currently working on a video-installation where i would like the audience to be able to interact with an image. I have figured out how to make the OSC listener connect to the horisontal movements of the audience, but not the vertical or the depth. I am quite new to this, and have been going through multiple tutorials to set it up.

    Even when i connect the OSC listener to something large, like the torso, it does not react to vertical movement. Is it possible i need a newer Kinect? 

    I am using a Kinect 1414, Ni-Mate, Spout in to Isadora.

    Any help / suggestions would be appreciated! 



  • if you are getting one set of OSC from NIMate, you are probably getting all the OSC you need.

    things to check: go to Stream Setup - check Auto-Detect and see what's coming through from NIMate. select the OSC that you want to use and give it a channel number. if you are tracking the torso, then NIMate will be sending out OSC for 3 or 4 values - usually X, Y, Z and Velocity, in that order. if you assign channel1 to this stream, then channel1 = horiz, 2 = vertical, 3 = depth. you then need 3 separate OSC Watcher actors, set to channels 1, 2 and 3. - then send the output of these into Limit-Scale Value Actors to scale the data to something useful.

    which version of NIMate are you using? if its v2, then you might need to make sure you are sending OSC properly. Sending it from the Control menu is usually easier than from the Skeleton menu.



  • @dbini

    Im using Ni-Mate v2. Ill try out the settings you mentioned and post my progress, thank you for the suggestions



  • @dbini

    It worked! You were correct, it (seems) to only work from the control-menu. 

    Thank you!


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.