assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Critical Aspect Ratio issues in Windows. [SOLVED]


  • Beta Gold

    Hi @DusX , @Skulpture 

    I'm having serious aspect ratio issues in Windows with the current version 2.5.3b5 which are making my videos look crap.
    Either this is a big bug or embarrassing user error. I'd be grateful if you could check and feedback to me.

    I'm working in 4:3, with Projection Design / Barco F32SX+ projectors, which have a native resolution of 1400 x 1050.

    I am creating artwork, stills and video, to this pixel dimension.
    When I bring them into Isadora, and play them, via picture player or movie player, Isadora renders them as squeezed, putting black bars at the top and bottom of my 4:3 output.
    If I change the 'keep aspect' setting of Isadora's projector actor to 'off' then the media is rendered in the correct ratio, but the image is jagged beyond belief. In short, the media looks awful. Totally unacceptable.

    In the help for the Projector Actor is says that with 'keep aspect' on, it respects the aspect ratio of the incoming video stream, and letterboxes horizontally or vertically as necessary. This is clearly not the case: Isadora is letterboxing and squeezing when it should not be altering the video at all.
    When you bring a 16:9 image in to the project, Isadora correctly letterboxes it automatically. Though the image still looks much more jagged than the original.

    What I think is happening is that Isadora sees a 4:3 file and letterboxes it when - for a 4:3 project - it should leave it alone, and for a 16:9 project it should pillar box it (vertical letterboxing).

    I'm attaching an Isadora project and a couple of test files. Isadora correctly sees the projectors as 1400 x 1050 and in the preferences it says 'keep aspect ratio'
    Look at these files in your favourite viewer. Note the roundness of the circles, and the complete lack of jaggies. Now open them in Isadora, preferably with your stage set to a 4:3 aspect ratio.

    The show's on Saturday. Would really appreciate any insight/ fixes/workarounds.
    If this is a bug let me know and I'll file real bug report, but for the moment....

    Thanks a lot guys, really appreciate your help on this.

    Cheers

    Mark (t'other one)

    1080 target.png
    1080 target.png
    1400 x 1050 target_1.mp4
    aspect issues.izz






  • I was able to duplicate your issue when I forced the default resolution. 

    Leaving the option to the smallest or highest, or if you force it to match your media, then it should be ok.

    forced to unmatched ratio

    default


  • Beta Gold

    @LPmode


    Thanks, mate, you're an absolute star. By changing the Video Image Processing -> Default Resolution to 1400 x 1050 things are looking a lot better.
    I really appreciate your input.

    Cheers

    Mark (t'other one)



  • Tech Staff

    Massive thanks to @LPmode for jumping is so quickly here. I love this forum and community. 

    We will look into this - glad there has been a solution shared. 


  • Beta Gold

    @Skulpture

    Yup, this community is wonderful. From having spent a day with high anxiety levels to getting a solution within minutes... the relief was palpable!
    So what I'm curious about, Graham, is whether this is my error in how I've set up Isadora in the first place, or whether it's actually an Isadora issue.
    If the former, it'd be good to get a guide to setting up Isadora to match a particular output setting. I glanced at the manual to see: maybe I missed it. I just assumed that Isadora - which seems to operate on percentage rather than actual pixel dimensions - would automatically match 'project' ratio to stage ratio, but maybe that's an assumption too far and negates Isadora's flexibility?

    Cheers

    Mark (no, not that one)



  • @mark_m

    Thanks again to @LPmode for the quick help, but for the general user base I want to emphasize that using the "Scale to Default Resolution" option in the Preferences is not a best practice.

    There's no need for to use that setting to solve your problem. If you choose "Scale to Smallest" or "Scale to Largest" then everything will work as you expect, and you won't need to change the default resolution in the preferences for every project.

    I just tested your 1400x1050 movie in a preview Stage window set to exactly half that size, and the image touches all the edges. The only time Isadora will letter box an image is if the aspect ratio of the image doesn't match the aspect ratio of the output.

    Best Wishes,
    Mark


  • Beta Gold

    @mark

    Thanks for your help. Really appreciate it. Good to know these things. Project looking great now, thanks.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.