assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Problem with saving Apple Script into Folder Action Scripts (for automatic load in media into Izzy)



  • Hi All,

    I am having trouble saving the apple script code into the "folder action scripts" folder. It's the script that Mark have posted for Isadora to watch a folder for any new photo or videos, it automatically imports into Isadora, which worked in my previous machine but not this current one. I have done the exact same procedure and even tried moving IsadoraCore software into the application folder outside of the Isadora folder. 

    the only problem that I can think of is that after I pasted the script into AppleScript Editor and try to save it into the Folder Action Script folder, it asked me to "Where is Isadora?" and there's a window of applications that popped up, Isadora wasn't there and there is a Browse botton, I pressed and try to location my current Isadora "IsadoraCore USB Key"  under application -> Isadora ->IsadoraCore USB Key. it automatically changed the script to tell application "IsadoraCore USB Key",instead of "isadora" which is the original script. I'm not sure if this what makes the issue why I cannot save the script. it says "the document "untitled" cannot be saved as "untitled". I tried all kinds of tiles but it all doesn't work. even adding .scpt extensions.

    here's the original script that was provided by Mark in the previous forum: (Jamie also shared this on her lovely blog)
    http://forum.troikatronix.com/cgi-bin/forum/gforum.cgi?post=957;search_string=watch folder;guest=21839142&t=search_engine#957

    1) Enter the following script into the Script Editor application 

    --- SCRIPT STARTS HERE 

    on adding folder items to this_folder after receiving these_items 

    try 
    tell application "Isadora" 
    import media into document 1 from these_items 
    end tell 

    on error msg 
    display dialog "Error importing file into Isadora: " & msg 
    end try 

    end adding folder items to 

    -- SCRIPT ENDS HERE 

    Thank you very much in advance. My backup plan is to use my old machine until this issue gets solved, hopefully soon. 

    Sammy



  • My friend Stefan Smulovitz has helped me figured out what the problem was. it's actually quite simple, just a permission issue. So instead of trying to save the script directly into the library folder, save it onto desktop or somewhere else that doesn't implicate any permission issue, then drag the saved script into the right folder inside library and it worked fine. Just want to share with everyone in case anyone encounter similar problems in the future.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.