assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Video input settings does not get saved



  • Hi,

    I have a usb-camera (Microsoft Lifecam 720p30) as a live video input source and it is working fine. However if I do some changes to the camera settings (Live Capture Settings -> Video Input -> Settings), changing the Brightness and Compression settings for instance, these changes does not seem to get saved?
    If I save the project and restart Isadora the camera settings are all reset to default, it's actually enough for me to uncheck and the recheck the Channel Select box and the settings are reset again.
    Is there any way to get the changes I do to stick?
    I'm using Isadora 1.3.0f24 on a MacMini with OS X 10.8.1.


  • Dear pdab,

    In the video tab of the Isadora Preferences, try turning on the Load/Save All Settings When Starting/Stopping Live input. This will slow down the speed at which the Live Input starts up, but this only matters if you are using the Capture Control actor to turn the live input on and off interactively.
    Best Wishes,
    Mark


  • Ok so that works for turning live input on and off, but if I restart Isadora, the settings for the camera are back to the default values, these strange "default values", where do they come from?!.
    Since we're setting up a machine for a client, I would like the camera settings we set up (saturation, brightness etc) to be the same even after a restart. However I try though, the settings are always reverted to the default settings?
    Is there any way to change these default settings? I've searched the webb for info but not found much of use there.
    I downloaded a program called 'Webcam settings' where you can do all sorts of tweaking to almost any Usb-connected camera but you cannot save these settings so that they are automaticly loaded when Isadora starts the Live input.

    Any ideas would be much appreciated.


  • Tech Staff

    Another program called iglasses can save the settings and iglasse then apears as camera in Isadora. It's not free but has a free demo.

    Best,
    Michel



  • Well, I downloaded the iglasses demo but I can't get it to run in Isadora, if I choose iglasses as the camera input and then start Live Capture Isadora crashes with the error:
    !(result == noErr)
    CVideoCapture.cp
    1066

    If I choose iglasses in Isadora (without starting live capture) and the go in to settings I can get iglasses to start up, but as soon as I exit settings Iglasses shuts down, and if I then press Start Live Capture Isadora crashes again with the same error info?

    iglasses seems to work fine in other applications but not in Isadora.


  • Tech Staff

    @pdab
    It does work fine on my computer. When you buy it you also have more options. I tried it with Isadora 1.3f24 and it didn't work there but with version 1.3f25 it does. Opens automatically when you choose it in Isadora. Try that.

    Best,
    Michel



  • Dear pdlab,

    Well, I went in to Isadora and verified that the function that saves and loads the video capture settings works -- at least on my internal FaceTime HD camera. 
    Part of the problem is that while the functions that get/save these settings may not return an error, it may not be consistently implemented on all drivers.
    I don't know if there is more I can do without a Blackmagic card at this time.
    Best Wishes,
    Mark


  • I tried iGlasses with 1.3f25 but that didn't work either, strangely enough, after going back to 1.3f24 it actually started working, I have no idea why.
    Thanks for the help!


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.