assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Isadora periodically dropping connection with TouchOSC?



  • Hi, I'm wondering if anyone has any OSC advice/knowledge to share. I'm controlling an Izzy patch for the first time with TouchOSC on my iPad (thanks to @Skulpture for the tutorials). I have everything working fine, but periodically (and unpredictably) the OSC Listener actors just stop receiving messages. I'll tap on a button in TouchOSC and nothing happens.

    What's strange is that, if I go to Stream Setup and Auto Detect Input, Isadora shows that it is receiving data when I push buttons & move sliders. However the OSC Listener actors don't respond. 
    If I close and re-open the file it still doesn't work. The only thing that fixes it is to fully quit Isadora and restart the app. 
    Any ideas as to why this is happening? 
    One thing I noticed is that there was a slider that I had previously deleted from my TouchOSC interface, but it was still listed in the Isadora Port/Stream Address settings. Could that have caused the Listeners to go dead? I deleted that control setting but I'm not convinced it fixed it.
    As for my setup: Mac Pro, OSX 10.8.2, IsadoraCore 1.3.0f24, iPad 3 with iOS 6.0.2. 
    Mac Pro is connected to a Netgear router via ethernet, iPad connected via Wifi. They are both set to use DHCP with manual IP addresses. 

  • Tech Staff

    Hmmm strange. It is likely it is not isadora but the network and IP/OSC exchange. Maybe change the IP number to something similar but not the same; for example instead of 192.144.0.6. Hangs it to 192.143.0.6? So it's still in the same range.



  • I thought it could be some networking issue too, but given that Isadora does see the communications in the Stream Setup (just not the OSC Listener actor) I'm thinking it's something funky within the application...



  • What kind of duration are we talking about? Hours? Days? And did you do anything in between that could have affected things, e.g., go to sleep?

    Best Wishes,
    Mark

  • Tech Staff

    It unlikely.... but do you have any firewall software enabled or anti-virus stuff going on?

    I have only once seen this stop OSC data on a students laptop machine a few years back.... just a thought.


  • @Skulpture: I only had the default OSX firewall turned on and Isadora had permission to send/receive data. I turned it off just to be safe.

    @mark: Everything was working fine, then the problems started happening after 5-10 minutes. No things were going on in between, i.e. the computer and iPad sleeping, that could cause a disconnect.


  • Dear Dappertutto,

    Well, regarding the sleep issue, I've submitted a bug report to myself to check this. I'll let you know what I find out.
    -- M


  • Along similar lines.... I am having a hell of a problem to get my iphone 4s version of OSC to connect to my network.
    OSC will not find my host, so I have to add it manually, and still it is hit and miss for hours at a time (sometimes) to get the stoopid thing to see my MacPro.
    Cancel, quit, restart... the works.
    Once it does connect, it is solid - until I step away for a few hours, then the fight begins all over again.

    I am using all current versions and trying to connect to my Apple Airport.
    No anti-virus, no special firewall (only basic Mac network).
    Is there a "right" sequence of events to get it to communicate?  Turn puter on, start touchOSC editor, then turn on phone... that kind of thing?

    I feel it must be a network issue - but I wouldn't know where to start tracking that down.
    Would anyone reading have any links that would point me to some basic network / setup advice?

    Thanks Kindly.
    -DG



  • Dear Chizzer,

    Three days ago I was in the midst of writing this tutorial when the whole forum went "bonk." But perhaps following it through will help you. Give it a go.
    http://troikatronix.com/support/kb/using-touchosc-with-isadora/
    Best Wishes,
    Mark


  • This is very helpful.
    Thank you.


Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.