assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[SOLVED] controlling lights slow down frame-rate using Enttec DMX to usb



  • I've been using MAX to send DMX via Enttec DMX USB Pro in the past years to control PAR LED lights, I just recently switched to Isadora since Werkstatt 2016 so I won't need to send OSC from Izzy to MAX anymore. However, I realized that if I do manual changes on parameters, izzy has no issues, but if i'm sending constant change values such as sound tracking or Wave Generator, izzy will slow down to 20 FPS or less, you can see Wave Generator having hard time producing smooth values, the value stutters. It becomes really noticeable after 4 or 5 values are changing at the same time. I've tried to convert the value to integer and the result remains similar.

    My solution now is to use izzy to control lights only if I'm just switching lights at a one time command, if I need to do anything more complex such as sound tracking or autonomous parameter variations, I would send OSC to MAX instead. And also to note that you cannot connect the Enttec to both izzy and MAX at the same time, the device crashes. This is my solution for now, but I thought to report this just in case anyone else have found other solutions or if this is worth looking into. I've attached the patch here enttec-user-actor-demo-troubleshoot1.izz


     


  • Beta Platinum

    @chimerik

    Hi there ! I used the Enttec User actor with the live breathing of a actor using OSC and a breathing 'sensor' belt. I never experienced stuttering with that setup.

    The Enttec DMX Pro settings allow to set the refresh rate of the hardware. 1 - 40 FPS. You are currently sending a change from 1-100 (in small steps) in a frequency of 1Hz. Could it be that the Matrix Send is getting overloaded ? Or that the Hardware can't keep up with the matrix send ? If you open the Enttec Send Actor you see a Matrix Value receive Actor that has a setting called 'min period', perhaps this can help you out ?


  • Tech Staff

    I would agree that it's most likely that you are a sending values at a very hight rate. Throttle it back a bit and I am sure Isadoras perforce will bounce back.


  • Tech Staff

    @chimerik 

    Yes you have to set the value of the "min period" to something higher than 0. It helped me by just setting it to 1ms, but as the help description says if you send all 512 channels you should set it to 24ms.

    Best Michel



  • Thank you Juriaan, Ryan & Michel! Sorry that I went into full production mode and didn't get a chance to check the thread until now. The method of going into the ENTTEC Send Actor and changing the 'min period' has resolved the overloading issue. I just changed my number to "2ms" and the FPS went back up to 30 already. I will keep testing in real situations and let you guys know if anything else I found, otherwise this topic is resolved for now! Thanks so much!