assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Minor issue with Isadora 2.6 stages



  • Thousand thanks for the new update 2.6!!!

    In previous version, I was able to have multiple stages running, even I had only one existing screen that was assigned to a stage – the other stages were "hidden" (dragged outside the screen area, and only a small corner visible), and could be used for recording a stage other than the one visible. And Isadora remembered this placement (dragged the extra stages "hidden"), in other words the stages stayed "hidden" in the corner. However, now with version 2.6, when Isadora is restarted, the extra stages come over to cover the assigned stage.

    It would be nice if also Isadora 2.6 would remember the stage placement, making it unnecessary to rearrange all the stages whenever the application is started. (Even nicer, if the extra stages were possible to hide totally, to get rid of the white bit in the corner.) 

    Would this be possible in the next update?

    Thanks in advance,

    Lauri



  • @lauri said:

    However, now with version 2.6, when Isadora is restarted, the extra stages come over to cover the assigned stage.

    I am testing this right now on a Mac. I have a full screen stage on the external monitor, and the two stages are at the very bottom of the screen so I can only see the title bars. When I restart Isadora everything is exactly where I placed it.

    Are you also working on a Mac? Or on a PC?

    Best Wishes,
    Mark



  • @mark Thank you for replying!

    Yes, I'm on a MacBookPro (late 2016), OSX 10.12.6. For the moment, I do not have external monitors, just the laptop screen. The strange thing is that the issue does not happen on Isadora v.2.5.2, only v.2.6.

    I can test it with MacPro (OSX 10.11.x) + external monitors (and laptop+monitor) later when at my studio – maybe weekend or next week.



  • @mark 

    I tested the issue with the MacBookPro (OSX10.12.6) and external display hooked on, and while having the external display, the issue vanishes. So, the stage placements are remembered when there's more that just the laptop's display, even after restarting the application.

    However, I tried the same with MacPro (2013) (OSX10.11.x). There's no problem if I have two monitors. But the same issue appears, if I have only one display hooked on the MacPro. And even more, the issue appears after each time I close the project (not the Isadora application).

    So, for me, this is a bit of a problem, and hopefully there's a remedy coming with the next upgrade.

    In addition, sometimes in Isadora v.2.6, when pausing the engine and changing something (like the actors or settings in the stage, changing or adding imported media, …) the resume engine is greyed (non fuctional) as well as the whole “Isadora” menu (including Quit Isadora). (Saving the project is possible.) Choosing another stage does not help. So, to continue, the only possible way is to Force Quit Isadora and relaunch it. Isadora application is not crashing, it's just jammed. Unfortunately, I don't know how to repeat this, it seems to happen randomly, not frequently, but often enough.

    Thanks for your help in advance!

    Best Wishes,

    Lauri



  • @Lauri 

    I guess I'm not totally understanding your problem.

    I tried this with no external displays, and the windows always show up in the same place.

    I'm going to ask you to give us a really precise step-by-step so we can help you, e.g.,

    1) Open Isadora with (No/One/Two) external monitors attached
    2) Set Preferences to show X stages, routing Stage 1 to Display 2, etc
    3) Show stages
    4) Place preview of Stage X at very bottom right of main display/extneral display, so that only title bar is visible
    5) Place preview of Stage Y at top left of display, so only very right edge of preview is visible

    Something like that so we can really follow your steps exactly. If you are adding/removing display between the runs of Isadora, make sure to indicate that.

    OK?

    Best Wishes,
    Mark 



  • @mark 

    Thanks for replying! Ok, no problem.

    So here’s what I’ve done on a MacBookPro (OSX10.12.6):

    1) Open Isadora 2.6 with no external monitors attached

    2) Set Preferences to show:

    Stage 1 on “Main Display” (Limit To 16x9)

    Stage 2 “none” (Match Display Aspect)

    Stage 3 “Display 3” (Limit To 16x9)

    Stage 4 “none” (Match Display Aspect)

    Stage 5 “none” (Match Display Aspect)

    Stage 6 “none” (Match Display Aspect)

    3) Show stages (when project running)

    4) Place preview of Stage 3 at bottom right of Main Display so that only the left tip of the title bar is visible on the left bottom corner of Main Display.

    5) Closing Isadora 2.6

    6) Restarting Isadora 2.6

    7) Open (and running) the project 

    8) Show stages: on the Main Display Stage 3 is located on top of Stage 1, not so that only the left tip of the title bar is visible on the left bottom corner of Main Display (as it was before closing Isadora 2.6)

    This does not happen when I have an external monitor. 

    And here’s what I’ve done on a MacPro (10.11.6):

    1) Open Isadora 2.6 with no external monitors attached

    2) Set Preferences to show:

    Stage 1 on “Main Display” (Limit To 16x9)

    Stage 2 “none” (Match Display Aspect)

    Stage 3 “Display 3” (Limit To 16x9)

    Stage 4 “none” (Match Display Aspect)

    Stage 5 “none” (Match Display Aspect)

    Stage 6 “none” (Match Display Aspect)

    3) Show stages (when project running)

    4) Place preview of Stage 3 at bottom right of Main Display so that only the left tip of the title bar is visible on the left bottom corner of Main Display.

    5) Closing project

    6) Open (and running) the project 

    7) Show stages: on the Main Display Stage 3 is located on top of Stage 1, not so that only the left tip of the title bar is visible on the left bottom corner of Main Display (as it was before closing the project)

    This does not happen when I have an external monitor

    Hope this helps. And thanks again for trying to solve the problem!

    Best wishes,

    Lauri



  • @Lauri 

    Your step by step did the trick. I see the problem and I'll fix it.

    Best Wishes,
    Mark


 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.