File Conversion Problem (Streamclip)

  • Hello all,

    I am new to the Izzy community and am having some newbie problems converting the format of some of my footage.  I am using Mpeg Streamclip (as it was recommended to me).  I am trying to convert the format of an .mp4 to an .mov with photo jpeg codec.  I understand izzy uses this format best.  However, when using Streamclip I get an error "can't prepare the movie."  I have VLC installed, so, I should have all the codecs, no?  Something I am missing?  I have searched forum after forum and found folks with the same problem but no solutions.  The only thing I found that I may need is QuickTime MPEG-2 Playback Compnent.  Please advise and thanks in advance!
    I should also mention I am using OSX 10.6.8 on an Intel Macbook Pro.


  • Izzy Guru

    Never heard of that problem. I have used Mpeg stream clip for several years now. Maybe it is the MPEG-2?

  • This most likely covers you problem I think. However it may not give you the solution. Sometimes simple change the mp4 to mov in finder will help. Otherwise it is the codec inside the mp4 container that is not recognized by Quicktime.

  • if Vanakaru's solution doesn't work, i find that Handbrake is pretty good at recoding .mp4s into something that MPEGstreamclip can then handle.

  • Thanks for responding.

    Vanakaru, thanks for the link.  I tried installing Perian as the forum link suggested but it did not solve the error I'm getting.
    To be clear, Streamclip will play the movie I open in it, it just won't Export to Quicktime (or DV or AVI etc.).  So, I find it strange that Streamclip sees and can play back the clip but it can not export it.
    Skulpure, it's very strange indeed.  Streamclip came highly recommended to me and after reading about it I'll be disappointed if I can't get it opporating properly.  I think I will try buying and installing the $20 MPEG 2 component.  Though, I'm not sure it will help me with .mov and .mp4... but for $20 it's worth a try.
    Dbini - thanks for the recommend.  I think I will use Handbrake, as it was also recommended to me, if I'm unable to find a solution to this.
    I'll be in touch with an update - additional advice is welcome.  

  • Okay... So before deciding to buy and install the MPEG 2 Component from Apple I decided to go back to Streamclip's website one last time.  On a hunch I decided to download their beta version (1.9.3b8).  I had been using 1.9.2.  With the beta version installed I tried converting again...and it actually worked!  I wish I had a more concrete idea or reason as to what the actual problem was, but, at this point, I'm just pleased that it is working!

  • Izzy Guru

    Glad you got it working!