assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

[SOLVED] Optimize setting on movie player not behaving the same on different computers



  • On my Macbook Pro I am playing a movie through a Movie player with the optimize setting on interactive and it works fine.

    When I move it over to my Mac Pro the video looks like it is playing but only outputs a transparent stream of video. (It shows the grid pattern in the little preview that pops up when you hover over a connection line down stream of the movie player. If I change the playback type to performance, the video starts streaming.

    The video is encoded in HAP1 and both machines have the codec installed. Both machines are accessing their own clone of the same isadora file and source videos.

    The original video is in a strange resolution of 720x1280 (was taken with an phone originally)

    On the MacPro: When it is in interactive mode this is the resolution that it shows and it notes that the alpha is "straight" in the preview window that pops up when you hover over a connection line down stream of the movie player. The movie player also shows that it is using the QT pb engine

    When I change to performance mode the video output of the file changes to 1280x720 and the pb engine changes to AV.

    On the MacBook Pro the only difference is that the video is visible in both modes - though the image does shift its composition as the resolution flips from 720x1080 to 1080x720 between the two modes.

    While am I able to move forward by not using the interactive setting and recompose the video with the performance mode - any guidance on why this happening would be helpful as I anticipate wanting to actually be able to use both modes at some point.

    Thank you Isadora forum! You are awesome.

    -Alex


  • Tech Staff

    @aolis

    Are you running the latest Isadora version, 2.6.1 ?



  • @DusX Sorry, yes - I am running 2.6.1



  • @dusx

    Don't know if it matters, but the Macbook Pro has a local license and the Mac Pro is on a USB license.

     



  • Dear @Aolis 

    Well, I don't have a Mac Pro but just exported a HAP1  to 720 x 1280. Plays correctly at this resolution in both performance and optimize modes. (No changing of resolution.)

    Does anyone here have a Mac Pro? Would you be willing to try to play this clip. I can send you a link for you to download it.

    One little note on your comments. You say "it notes that the alpha is "straight" in the preview window." It only says that because 'straight' is chosen as the alpha mode of the Movie Player. If you change that input to 'premultiplied' you'll see the notation changes in the thumbnail. The user determines whether a video is straight or premultiplied alpha.

    One thing to check: is the QuickTime HAP codec the same on both machines? It's at /Library/Extensions/Hap.component -- don't trust the file date. Instead do get info and compare the size in bytes. Are they exactly the same? Latest codec for QuickTime is at this link

    Best Wishes,
    Mark 



  • @mark 

    I tested the file you PM'd me and I then tested a few other files that were encoded at the same time and in the same resoultion as the one causing me trouble and they all played fine. Perhaps it is just this single video that has something wrong with it.

    Regardless, I will double check the HAP codec as you mention here and also try re-encoding the individual video that seems to be having this issue.

    Thank you so much!!!!

    -Alex

     


 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.