4 Video Playback Question

  • Hi All,

    I'm using a simple 4 stream player 1080i 29.97fps videos as Apple ProRez 422 .mov rapper. In the system settings I've tried 29.97, 30, 60 75 fps and I can't get smooth live looking video playback.

    If I play more than 1 video at a time the frame rate goes down to 16fps playing the 4 videos (all the same video). I've tried HAP, DNX, Prorez, H.264 and they're all the same so far.

    I've even tried 3 different mac computers and a PC all with the same outcome. Granted I'm critically viewing, and this may be a quicktime problem and nothing to do with Isadora.

    This last test I'm using a MacPro with it's internal SSD as the media drive.

    This computer is running OS 10.11.6 and Isadora 2.5.2. This is my show computer so I can't update it to 2.6.1 until the bugs are flushed out.

  • Tech Staff


    On this machine with a SSD can you not play at least 2 hd videos smoothly? 4 maybe a stretch for the drives data-transfer capabilities.

    Also if using prores be sure to set the movie player to 'performance' not 'interactive' to have the videos played by AV foundation rather than QuickTime. 

    In 2.6.1 you can play Hap via AV foundation. Another great option.

  • Thanks, I did try AV vs. QT vs. DS.

  • I see you switched to a mac pro on the last test, this is your playback machine?

    What read/write speeds do you get with your SSD tested, not on the box?

    What mac pro, is it the trashcan or a cheese grater? 

    What GFX card is in there?

    How are you connecting 4 HD projectors?

    Basicallly 4xHD is 4k, I have been able to do this with recent gear, but I never use the newMac Pros, but I have had some good experiences with a recent cheesegratter with a 1080ti.

    In theory this should all be ok, but some more details about your system can help understand what the issue is.

  • It's a trashcan with an AMD D300 graphics card. 12g of Ram.  BM speed test is all green checks, so the HD is fast enough.

    And it's not only with 4, even 1 or 2 it can't keep the frame rate at a constant 30f. Maybe a quicktime problem I'm not sure.

    Like I said, I'm critically viewing and when the frame rate falls it's noticeable.

    Didn't want to waist anyones time, just curious.

  • @craigw ok, so the d300 is a pretty small card but should be able to handle this. I had 3 full hd videos with scenes that were crossfading to another set of 3 full hd on a MacBook Pro with a 2 gig gfx card with Isadora 2.5 and it was fine, so spec wise it may be tight but ok.

    I would go for ProRes (that is what I used in the above scenario), the frames are compressed but much easier to decode the h264, bigger files but easier on the system.

    When using ProRes or h264 the playback engine should be avfoundation, not quicktime, can you check that with your movie player?

    The only thing I can think of is, there is something eating resources on your machine, or the compression is messing with the decode, or these trashcan had a serious design flaw and get very early thermal throttling, there was a quiet recall for those who pushed it to apple. If you use some kind of GPU profiler when you run Isadora that may give you a clue.

    One other things that made a big difference is refresh rates. Make sure all your outputs have the same refresh rate even your control screen, so if one is 25p all screens and outputs are 25p or whatever refresh your videos are.

    Also try change the general service task settings.

  • Dear @craigw 

    I've just read through all this and certainly it is mystifying. You're aware of the issue of running Adobe Creative cloud right? This absolutely needs to be turned off if, by some chance, you have it installed on the computer and it is running.

    But when you say the frame rate goes down to 16fps, that really indicates something is "rotten in Denmark." I mean, I can play 4 x 1080p HD Apple Pro Res 422 on my laptop (though, granted, it's not to four separate monitors.)

    Have you read this KB article about configuring your monitors? If Isadora were unable to work with one OpenGL context, that might cause the problems you are seeing. One important test: Go to Isadora Preferences > Video > OpenGL and check the Disable Vertical Retrace Sync checkbox. Does that change the frame rate or other issues you have?

    If not, then I would follow up on @Fred's comments about the monitor refresh rate. In addition, I would also ask you to try is to add one monitor at a time, to find out if it's fine with two but not with three, etc. This would 

    If you switch to Stage Preview, does it change the behavior and smoothness?

    What happens if you switch to the Control Panel view – i.e., hide the actors by typing Command-Shift-C. Does that change anything?

    Silly question since you tried this on multiple computers, but is your computer dirty on the inside? (On my laptop this summer, plugging in an external monitor decreased the frame rate to 5fps... turns out the inside of my machine was filthy and it was overheating. Once I had it cleaned by a pro, it was all fine again, knock wood.)

    Finally, you say "This is my show computer so I can't update it to 2.6.1 until the bugs are flushed out." Currently, there are no serious bugs that we know about. I have a couple of minor things, but they wouldn't affect movie playback anyway. I would encourage you to at least try v2.6.1 (keeping v2.5.2 on your machine) if only so you can tell us if it behaves differently.

    I hope one of the suggestions above will help. Please let us know.

    Best Wishes,

  • Thanks Mark, In the past I did all those suggestions, It's been awhile though so I'll go through them again.

  • I was using another Izzy file with no video and 12-15 picture players. Frame Rate was down to 8fps with 44 cycles and very sluggish to use. I started deleting things, I deleted the 3 Gaussian Blurs and it went back up to 60fps and 775 cycles.

  • Tech Staff

    Where the Gaussian blurs, gpu or cpu?

    If cpu, its very possible that your cpu was at max usage. (check in activity monitor)

    if gpu based, you may have maxed your gpu memory or over heated. I would suggest looking for a gpu monitoring tool (I use GPUz on PC, sorry I don't know a mac tool off hand)

  • @craigw said:

    I deleted the 3 Gaussian Blurs and it went back up to 60fps and 775 cycles.

    Well, there's no way around this fact: blurs are  computationally intensive even for the GPU. If they 12 pictures were very high res I can see that the Gaussian Blur might cause this problem, even if it was GPU. Still, it would be good to know the resolution of the images and if you were using CPU or GPU gaussian blur, just so we have a sense of what went wrong here.

    Best Wishes,

  • Hi, It's the GPU version of Gaussian blur. Most of the pics were 1920x1080 jpegs, some were 1920x1080 pngs with an alpha.

  • Oh, I did update the computer to 2.6.1 also and no change.

  • I'm starting to see a big powerful PC in my future.

  • @craigw said:

    Most of the pics were 1920x1080 jpegs, some were 1920x1080 pngs with an alpha.

     So you're saying 12 to 15 instances of x 1920x1080 images going through the Gaussian Blur actor, yes?

    I forgot to ask: what was the blur setting at? That's important... higher is slower for sure.

    Best Wishes,

  • No, only 1 pic per gaussian blur. So 3 pics and 3 Blurs.

  • @craigw said:

    No, only 1 pic per gaussian blur. So 3 pics and 3 Blurs.

     And the blur setting?

  • Almost max blur.

    So here's my time line. Opened the file. Heavy CPU load. Rebooted, same thing, heavy load. Deleted the gaussian blurs and all is good. Shut down computer for the day, started everything back up opened the same file that was giving me problems and now it's good. Aauugghh! So strange!

    I keep this computer free of everything so its only duty is Isadora.

    The activity monitor files attached are yesterdays bad, and todays good. The only change I see is the load from Isadora.

    At this stage it's a mystery to me. Next time, would it help if I ran a spindump for more data collecting?

Log in to reply

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.