Start 2 macs (one with logic one with isadora) with one midi command



  • hey there,

    i want to start a logic timeline and initialize a trigger with an actor in isadora simultaniously by using one midi controller to start audio (master) and video (slave) frame sync. i just set up a lan connection via midi-studio between the two macs, one as master, one as slave. the live-routing (slave) is set to "isadora virtual in". in isadora the midi setup, port 1 is also set to "isadora virtual in".

    the status window sais: last message SysEx: 7Eh 00h 06h 01h, but no green light is flashing. i found the msc watcher and added it to my stage. but if i push the button on my midi controller to start logic (master) the msc watcher (on the slave) doesn´t show any reaction. all i need is a little trigger...

    i guess there is something missing... any idea? maybe even a better / different one?

    thank´s stefanie



  • It is not entirely clear to me how you mean "set up a lan connection via midi-studio between the two macs". To check if you receive MIDI on second mac use MIDI Monitor.

    http://www.snoize.com/MIDIMonitor/

    But I would use MIDI multiplier box to connect two macs with controller
    MIDI controller>MIDI box>MIDI OUT 1 to one mac, MIDI OUT 2 to second mac. Macs need MIDI USB devises too.

    I do not like software routings and lan connections if I need reliability.


  • Tech Staff

    I did connect two mac's via a network cable to send and receive midi, it always worked fine. Here an article about connecting two mac's:
    http://www.soundonsound.com/sos/mar07/articles/dpworkshop_0307.htm

    Best,
    Michel



  • that´s what i´m looking for: the most riliable solution.
    these guys say they do have good experiences with lan, too:
    http://flipmu.com/2011/10/23/locked-in-the-groove-midi-sync-passing-midi-between-2-computers-in-ableton-live-mac/
    i followed up their instruction. but as they are working with ableton i´m lost right there.

    in my case the midi connection over lan seems to be fine, but how do i manage it in isadora? is the msc watcher the right one to read it?

    also i´m using one usb plug for my audio interface, one for a midi controller. i´d like to avoid to use a usb hub to plug another device. that´s always risky, isn´t it?
    best,
    stefanie

  • Tech Staff

    In the MIDI Network Setup you give a uniqe local and a Bonjour name for each computer. As soon as you activated it on both computers you have to add the other computer in the directory field. Add a port number beetween 1 and 16.
    In Isadora go to "Communications-->Midi Setup" there you choose the Bonjour Name you gave in the MIDI-Network setup to connect to the other mac.

    Depending what you are sending you have to use different actors either the "control watcher" "Note On" or "Note off" watcher or the "program change watcher" etc. make sure you set the right port number you have given.

    I would not do it with a wireless connection, that is not really riliable.

    Best
    Michel



  • all right, computers are activated, the connection is set up, but the port is set to 5006 by default. no change possible.

    what can i do?


  • ps: all i need is a trigger out in isadora to start the movie


  • Tech Staff

    I can type in any kind of port number. Can you post a screenshot of the window?

    Best
    Michel



  • what a shame. it got that small through the uplpload. here´s the detail

    .![](http://troikatronix.com/troikatronixforum/uploads/FileUpload/04/093dfb-setup_midi_sm.jpg)

    093dfb-setup_midi_sm.jpg


  • Tech Staff

    try it with port 5, it looks like the .006 seems something else. does that work?



  • unfortunately no, if i change the port i do get an alarm signal. but, i got a step further. i´m now sending the midi signal out of logic via a midi note, not via the external midi controller. this seems to work! if i start the timeline i do get a sysex message confirmation as attached. if i stop the timeline it sais "stop".

    on my stage i got the midi show control watcher, control watcher and note on watcher, but all of them are not reacting. ?
    best,
    stefanie
     ![](http://troikatronix.com/troikatronixforum/uploads/FileUpload/b0/3f55ea-status_sysex.jpg)

    3f55ea-status_sysex.jpg


  • Tech Staff

    Have you set up the port in Midi Setup?

    It's under Communcation

    644af0-screenshot_1.jpg


  • Tech Staff

    what port did you set in logic, and what midi source did you choose in Isadora?



  • in logic i´m sending on all ports (1-16), in the midi prefs, midi machine control, outgoing id and incoming id are set to 127 by default (no change possible)

    in the project prefs midi clock is sending to the network master comp, the same for midi time code, and midi machine control is enabled.
    **in the midi network configuration** "live routing" is set on the master to "master to network" and on the slave "network to isadora virtual in"
    **in isadora** in the midi setup i chose on port 1 "isadora virtual in". only by chosing the virtual in i can see the sysex message if i start and the "stop" if i stop in logic on the master. if i select the network "slave" on port 1 the "last message" in the status window is flipping between "start", "stop" and the sysex message.

  • Tech Staff

    Hi stefanie

    It seams to me that you don't understand how this is working. In your case, as you discribe you don't need Isadora virtual in or out, and you also don't have to set anything in "live routing" of the midi network configuration.
    See my attached image how it should look for example the master computer, here I sent a note on signal from the slave to the master, in the status window of Isadora you can see what was sent. In logic you also have to set master or slave for midi in and out if you want bi-directional communication.

    Best
    Michel
    2e187f-midisettings.png



  • yup, obviously there was a lack of understanding.

    i copied the midi note from the instrument layer to the external midi layer in logic. shame on me... now IT´S WORKING!!!!
    thank´s for your patience, michel!!
    by the way... yesterday we tried the solution with the midi interface emagic MT4 plus midi usb cable, works fine too. just more cables and an additional device.
    thank´s for your help!!!
    stefanie

Log in to reply
 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.