Movie Player Crashing with video input [on MacOS 10.9.5]

  • I have a student who has downloaded Isadora onto her computer. She opens the application, imports a video clip or two, then places a "movie player" actor in the scene - when she then enters "1" into the "movie" field and hits tab or enter, the application crashes. 

    She is on a Mac, as is many of the other students, none of whom are having this problem. 

    Any suggestions? 


  • Tech Staff


    We need much more information to help you here.
    What MacOS version does she use?
    What version is Isadora?
    What is the codec of the movie?

    Best Michel

  • i see the same problem.

    i'm on mac os 10.9.5

    isadora version 2.6.1

    any codec within the .mov makes it crash.  i've tried proress 422, photo jpg a and 264.

  • I've tried the same movies in a demo version of Isadora 2.6.1 on Mac OS X 10.12.1 and they all play successfully.

  • Tech Staff

    Dear @particlep and @DanielB 

    In our Support Policy it says that we support MacOS 10.10.x and above and Windows 10 and above (https://support.troikatronix.c...). As we move on to make the software better and play smooth with the newest operating systems we need to make a cut somewhere. Lots of new features that are implemented in Isadora are not fully supported by old operating systems and may cause crashes. So if you have the possibility to updated your computer to at least 10.10. this would be great. But I know if you have an old computer this might not be an option. @DanielB can you give as more information about the MacOS version on your students computer? @Mark what do you think?

    Best Michel

  • hi @DanielB

    i was in the same case (isadora 2.6.1, macos 10.9.5, and movie player crashing) and i 've found a way to deal with that...

    well it is not really a clean way but it works! I just add a file called "IzzyMoviePlayer64_NoHAP"  i've found in the 2.6.1b3 build that @Mark send me a month ago

    and now everything works as expected.


    you (or your student) have to place it in: Isadora/contents/MacOs (to find the "contents" folder you have to right click on isadora app. and then

    "show package contents" (or something similar: my Os version is in french...)

  • @artoo

    Thanks for jumping in here with that fix. I hadn't seen this thread until today, but you beat me to the punch.

    The problem is that 10.9 cannot support HAP playback on AV Foundation. While we no longer officially support anything less than 10.10 (and that will become strict in September 2018 with the release of Isadora v3) I discovered the problem and fixed it for @artoo. Hopefully it will eliminate the issue for @DanielB.

    Let me say it again: Isadora v3 will not run on anything earlier than 10.10. Please keep that in mind as we head towards that release.

    Best Wishes,

Log in to reply

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.