assurance-tunnel
assurance-tunnel
assurance-tunnel
assurance-tunnel

Frame rate drops with Sonnet eGPU Breakaway Box 550 + Vega 56 card - why?



  • Hello,


    I just installed a new ASUS Radeon RX Vega 56 Strix OC 8GB graphics card in my Sonnet Breakaway Box 550 eGPU and did a quick check if everything works with my Macbook Pro 15 TouchBar. The Mac recognised the card, I got a signal from both Displayport and HDMI, and did a speed test with GeekBench. So far everything seems to be working. 

    So I started Isadora 2.6.1 and played a ProRes Full HD 1080p25 movie that plays with 50 Frames with the internal Radeon Pro 560 graphics card of my Macbook Pro. But when I tried the eGPU output the frame rate significantly dropped to about 17.5 Frames. I tried both HDMI and DIsplayPort output, same effect.

    Why is this?

    M



  • @mrtz said:

    But when I tried the eGPU output the frame rate significantly dropped to about 17.5 Frames.

    The only thing I can offer right now is that we've never tried an eGPU with Isadora, so probably we can't say. One question is this: are you sure that all the textures are located on the same GPU? The issue could be this: there are two GPUs on your computer now, one internal and one external. Isadora may be allocating the textures (images, movies) on the internal GPU, and then to play then it has to move them – through the GPU – to the external GPU, which would definitely be slow. Put simply if one image is on GPU 1 and you try to render it to GPU 2, it's requires a copy via the GPU because the images are on two physically separate GPUs.

    This is the same problem Windows users can encounter if they have multiple GPUs installed in one computer. 

    You can try this: go to Isadora Preferences > Video > OpenGL > Shared OpenGL resources and disable it. When you do this, actors that generate video will all have their 'stage' input enabled, which will allow you to decide which video card it lives on.

    So, pleas try disabling Shared OpenGL Resources. Then full screen your stage on a GPU output, and specify that stage using the stage input of the Movie Player, does it make a difference?

    Another test: if you run your laptop in "closed display" mode - with the lid closed so the main GPU is not active and only the eGPU is active does that change things? That would be the only way I can think of currently to ensure that Isadora is only using the eGPU.

    Finally, Apple's own pages say that software developers are going to need to update their software to take advantage of eGPUs. This Ars Technica article mentions that even Apple's own Final Cut Pro does not take advantage of the eGPU. Obviously this is something we are going to need to work on.

    I can't offer a timeline on a fix at this point to help, but I would say there may be a shorter term solution to where you will need to specify which GPU Isadora uses. But this would probably require you to have your User Interface on the a display connected to the same GPU, not on the main display.

    Best Wishes,
    Mark



  • Hello Mark,

    Thanks for your quick answer! Today I tried again with the eGPU connected to 4 projectors, and Prores LT 1080p25 movies and  frame rates were much better. There was still some stuttering at one point so I tried to set the frame rate from ”50” to ”60” and so far it never dropped below 50, and I saw no stutters. Still its strange that connecting 4 outputs gave better frame rates then just 1 output.

    Closing the Macbook´s lid would only allow me to use 3 outputs of the eGPU. And I´d need another monitor, so that is no feasible option.

    I will try disabling the ”Shared Open GL resources”.

    Btw: I could lend you the eGPU box for sometime, if that would help finding a fix.

    Thanks,

    Moritz



  • @mrtz said:

    Btw: I could lend you the eGPU box for sometime, if that would help finding a fix.

    Well, I don't have a computer with Thunderbolt 3. But maybe I could have you stop by the office here in Berlin with your machine when I'm ready to try something out.

    Best Wishes,
    Mark



  • You´re welcome.


 

Looks like your connection to TroikaTronix Community Forum was lost, please wait while we try to reconnect.